Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1357154

Summary: Please back port the latest libsepol version to f24
Product: [Fedora] Fedora Reporter: Daniel Walsh <dwalsh>
Component: libsepolAssignee: Daniel Walsh <dwalsh>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 24CC: dwalsh, mgrepl, plautrba, pvn
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: libsepol-2.5-8.fc24 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-07-20 00:21:39 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Daniel Walsh 2016-07-15 21:45:57 UTC
We are seeing issues with docker-selinux on F24 caused by libsepol support for typebounds.  Can we back port these fixes.

Comment 1 Daniel Walsh 2016-07-15 21:46:17 UTC
https://github.com/docker/docker/issues/23981

Comment 2 Petr Lautrbach 2016-07-16 12:27:30 UTC
Does this update [1] work for you? Or do you need anything specific? It's based on the latest upstream sources and it's almost same as the Rawhide version.

[1] https://bodhi.fedoraproject.org/updates/FEDORA-2016-84d1f77e58

Comment 3 Daniel Walsh 2016-07-18 10:29:00 UTC
It should work for us.

Comment 4 Fedora Update System 2016-07-18 19:49:33 UTC
checkpolicy-2.5-6.fc24 libselinux-2.5-9.fc24 libsemanage-2.5-5.fc24 libsepol-2.5-8.fc24 policycoreutils-2.5-12.fc24 secilc-2.5-4.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-84d1f77e58

Comment 5 Fedora Update System 2016-07-20 00:20:57 UTC
checkpolicy-2.5-6.fc24, libselinux-2.5-9.fc24, libsemanage-2.5-5.fc24, libsepol-2.5-8.fc24, policycoreutils-2.5-12.fc24, secilc-2.5-4.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.