Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1356910

Summary: dnf does not respect per repository 'exclude=<versioned package spec>' settings
Product: [Fedora] Fedora Reporter: Jetchko Jekov <jetchko.jekov>
Component: dnfAssignee: Jaroslav Mracek <jmracek>
Status: CLOSED UPSTREAM QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: medium    
Version: 25CC: jetchko.jekov, jmracek, jsilhan, mluscon, packaging-team-maint, pnemade, rpm-software-management, vmukhame
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-09-08 18:08:58 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jetchko Jekov 2016-07-15 09:15:45 UTC
Description of problem:
I am trying to exclude specific version of package from repository. but DNF doesn't respect 'exclude=<versioned package spec>' in .repo files. 

Version-Release number of selected component (if applicable):
dnf-1.1.9-2.fc24.noarch
python3-dnf-1.1.9-2.fc24.noarch
python2-dnf-1.1.9-2.fc24.noarch

How reproducible: 

Steps to Reproduce:
1. 
set exclude=<package spec with ver> in some repo file
my current example: exclude=kf5-plasma-5.24.0-1.fc24 (currently broken in testing) which goes into /etc/yum.repos.d/fedora-updates-testing.repo

2.
execute relevant dnf update command
in my case
dnf --enablerepo=updates-testing  update


Actual results:
kf5-plasma-5.24.0-1.fc24 show as available update

Expected results:
kf5-plasma-5.24.0-1.fc24 MUST not be available as update

Additional info:

If I put same exclude line as a global setting in /etc/dnf/dnf.conf it is respected.

Using only package name (exclude=kde-plasma) in .repo file works as expected -> the package doesn't show as available update.

Comment 1 Honza Silhan 2016-07-18 11:17:51 UTC
We'll take a look

Comment 2 Jan Kurik 2016-07-26 05:01:41 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.

Comment 3 Jaroslav Mracek 2016-09-07 17:13:56 UTC
Please, can you try dnf-2.0 from copt repo. Just use command ``dnf copr enable rpmsoftwaremanagement/dnf-nightly`` and then upgrade dnf to version 2.0. According to my investigation, the problem is solve in this upstream version.

Comment 4 Jaroslav Mracek 2016-09-08 18:08:58 UTC
Probably it will be better to close the bug report but if you will experience the reported problem with dnf-2.0, please don't hesitate to reopen it and provide please fresh data.