Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1356488

Summary: Edit VM Pool show wrong storage domain
Product: [oVirt] ovirt-engine Reporter: Shahar Havivi <shavivi>
Component: Backend.CoreAssignee: Shahar Havivi <shavivi>
Status: CLOSED CURRENTRELEASE QA Contact: sefi litmanovich <slitmano>
Severity: high Docs Contact:
Priority: medium    
Version: 4.0.0CC: bugs, gklein, melewis, tjelinek
Target Milestone: ovirt-4.0.2Flags: rule-engine: ovirt-4.0.z+
rule-engine: planning_ack+
tjelinek: devel_ack+
mavital: testing_ack+
Target Release: 4.0.2   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
With this update, a new option been added to the options for a virtual machine pool for disk storage. This option allows the user to select Auto Select Disk Target, instead of a specific domain. This means that every new virtual machine in the pool will use the storage domain with the most available space.
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-08-12 14:24:13 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Virt RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1356492    
Bug Blocks: 1081536    

Description Shahar Havivi 2016-07-14 09:04:09 UTC
If template exists in more then one storage domain, edit vm pool always points to the first logical storage domain. (edit pool->resource allocation->disks allocation).

When increase VMs to the pool the disks will be allocated always in the first logical storage domain.

Comment 1 Red Hat Bugzilla Rules Engine 2016-07-14 09:04:47 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 2 sefi litmanovich 2016-08-02 08:56:15 UTC
Verified with rhevm-4.0.2.3-0.1.el7ev.noarch.

1. Have 2 SDs in DC.
2. Created template.
3. Copied template disk to 2nd SD.
4. Created vm pool: in resource allocation->disks allocation choose the 2nd logical SD.
5. Edit vm pool: increase by 1 vm, verified that in 'esource allocation->disks allocation' the SD is still the 2nd.
6. Verified the new vm was created under the 2nd SD.