Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1355922

Summary: Touchpad settings do not show in gnome-control-center
Product: [Fedora] Fedora Reporter: Murphy Zhou <xzhou>
Component: control-centerAssignee: Control Center Maintainer <control-center-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 24CC: control-center-maint, fmuellner, mkasik, ofourdan, rmatos, rstrode, tiagomatos, xzhou
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-08-25 10:18:02 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Murphy Zhou 2016-07-13 02:30:40 UTC
Description of problem:

T440s f24 gnome, in All settings -> Mouse & touchpad,

there are only 2 sections: general and mouse, no touchpad section.

However, it does show up in gnome-wayland session...

Version-Release number of selected component (if applicable):
f24 latest, upgrade from f23

How reproducible:
always

Steps to Reproduce:
1.

Actual results:
no touchpad settings

Expected results:
touchpad settings show up

Additional info:

Comment 1 Murphy Zhou 2016-08-24 02:04:31 UTC
ping

Comment 2 Rui Matos 2016-08-24 15:14:41 UTC
Does removing the synaptics driver make it work ?

See https://bugzilla.redhat.com/show_bug.cgi?id=1368800

Comment 3 Murphy Zhou 2016-08-25 02:48:02 UTC
(In reply to Rui Matos from comment #2)
> Does removing the synaptics driver make it work ?
> 
> See https://bugzilla.redhat.com/show_bug.cgi?id=1368800

Yes, install xorg-x11-drv-libinput and remove xorg-x11-drv-synaptics
make it work.

Thanks very much!

Comment 4 Rui Matos 2016-08-25 10:18:02 UTC

*** This bug has been marked as a duplicate of bug 1351013 ***

Comment 5 Murphy Zhou 2016-08-26 03:38:40 UTC
Another note:

mate-desktop needs xorg-x11-drv-synaptics which breaks gnome, so two fishes
in pool, one of them can swim..



$ sudo dnf install mate-desktop
Last metadata expiration check: 20:29:25 ago on Thu Aug 25 14:43:00 2016.
Dependencies resolved.
===================================================================================================================================================
 Package                                      Arch                         Version                             Repository                     Size
===================================================================================================================================================
Installing:
 mate-desktop                                 x86_64                       1.14.1-4.fc24                       updates                       109 k
 mate-user-guide                              noarch                       1.14.0-1.fc24                       fedora                        7.6 M
 xorg-x11-drv-synaptics                       x86_64                       1.8.3-2.fc24                        fedora                         92 k

Transaction Summary
===================================================================================================================================================
Install  3 Packages

Total download size: 7.8 M
Installed size: 22 M
Is this ok [y/N]: