Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1355894

Summary: [snap19] Unable to create composite content view via hammer
Product: Red Hat Satellite 6 Reporter: Mike McCune <mmccune>
Component: Content ManagementAssignee: satellite6-bugs <satellite6-bugs>
Status: CLOSED DUPLICATE QA Contact: Katello QA List <katello-qa-list>
Severity: high Docs Contact:
Priority: unspecified    
Version: 6.2.0CC: bbuckingham, cwelton
Target Milestone: UnspecifiedKeywords: Regression, Triaged
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-07-12 22:14:54 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Mike McCune 2016-07-12 21:09:56 UTC
1) Create some content views
2) Publish them
3) try to create a composite content view via hammer and see error:

# hammer content-view create --organization-id 3 --composite --name my_ak1 --component-ids 5,6
Could not create the content view:
  undefined method `composite?' for nil:NilClass

This was spun out of https://bugzilla.redhat.com/show_bug.cgi?id=1325124#c10

Comment 1 Brad Buckingham 2016-07-12 21:36:52 UTC
This looks like it may be the same as bug 1337746.  Refer to https://bugzilla.redhat.com/show_bug.cgi?id=1337746#c2 for workaround.

Comment 2 Mike McCune 2016-07-12 22:14:54 UTC

*** This bug has been marked as a duplicate of bug 1337746 ***