Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1355848

Summary: ceph-fuse is not linked with tcmalloc
Product: Red Hat Ceph Storage Reporter: Greg Farnum <gfarnum>
Component: BuildAssignee: Yan, Zheng <zyan>
Status: CLOSED ERRATA QA Contact: rakesh <rgowdege>
Severity: high Docs Contact:
Priority: unspecified    
Version: 2.0CC: ceph-qe-bugs, hnallurv, kdreyer, poelstra, vakulkar
Target Milestone: rc   
Target Release: 2.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: RHEL: ceph-10.2.2-22.el7cp Ubuntu: ceph_10.2.2-17redhat1xenial Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-08-23 19:44:11 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Greg Farnum 2016-07-12 17:45:05 UTC
Description of problem:
ceph-fuse is being built without being linked to tcmalloc. The default malloc is very bad; a ceph-users report on centos7 says he easily exceeds 10GB of VSS per process, and it is correlated with other issues that are still being pinned down.
(Past experience has shown us that using gmalloc also results in much worse throughput/IOPs in general.)

Version-Release number of selected component (if applicable): Downstream releases based on upstream Jewel, as well as upstream releases. See http://tracker.ceph.com/issues/16655


How reproducible:
It's a build issue.

Steps to Reproduce:
1. Build ceph-fuse
2. Observe it is not linked with tcmalloc


Expected results: ceph-fuse is linked with tcmalloc


Additional info:

Comment 4 Ken Dreyer (Red Hat) 2016-07-14 23:17:46 UTC
QE team: you can check this link by running "ldd /usr/bin/ceph-fuse | grep tcmalloc"

Comment 5 Yan, Zheng 2016-07-15 01:59:57 UTC
patch has been pushed into ceph-2-rhel-patches

Comment 9 rakesh 2016-07-25 10:43:14 UTC
As indicated by Ken, I have run the following command on RHEL and ubuntu,
   
-----ldd /usr/bin/ceph-fuse | grep tcmalloc

and here is the output

------libtcmalloc.so.4 => /lib64/libtcmalloc.so.4 (0x00007fce1a298000)

so moving the bug to verifed stage.

Comment 11 errata-xmlrpc 2016-08-23 19:44:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1755.html