Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1355594

Summary: Touchpad not found with kernel 4.6.3-300
Product: [Fedora] Fedora Reporter: Bhaskar S. Manda <bhaskarsmanda>
Component: plasma-desktopAssignee: KDE SIG <kde-sig>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 24CC: jgrulich, kde-sig, me, rdieter, rmiller61k, than
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-02-25 02:48:06 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Bhaskar S. Manda 2016-07-12 02:56:22 UTC
Description of problem:
On booting Fedora 24 with Linux kernel 4.6.3-300, and starting the touchpad configuration in system settings, a red bar on top reports "No touchpad found." The touchpad hardware functions in a limited way, with no button mappings, no scrolling, , no locked drags, lots of false clicks, etc. On booting back to kernel 4.5.7-300, full touchpad functionality is restored.

Version-Release number of selected component (if applicable):
Installed Packages
Name        : xorg-x11-drv-libinput
Arch        : x86_64
Epoch       : 0
Version     : 0.19.0
Release     : 1.fc24

Name        : xorg-x11-drv-synaptics
Arch        : x86_64
Epoch       : 0
Version     : 1.8.3
Release     : 2.fc24


How reproducible:
Boot into Fedora 24 kernel 4.6.3-300, and log into KDE environment.


Actual results:
Touchpad settngs reports that "No touchpad available." Limited and flaky touchpad functionality is present.

Expected results:
No error in settings. Full touchpad functionality.

Additional info:

Comment 1 Kevin Kofler 2016-07-12 10:06:14 UTC
kcm_touchpad has been part of plasma-desktop for ages.

Comment 2 Bhaskar S. Manda 2016-07-21 22:35:12 UTC
Problem persists with kernel 4.6.4-301.

Comment 3 Bhaskar S. Manda 2016-08-20 18:41:47 UTC
Problem persists in kernel 4.6.5. Following is the relevant difference between latest and most recent working kernel.

cat xinput.4.5.7-300.fc24.x86_64
Virtual core pointer                        id=2    [master pointer  (3)]
Virtual core XTEST pointer                    id=4    [slave  pointer  (2)]
FSPPS/2 Sentelic FingerSensingPad             id=11   [slave  pointer  (2)]


cat xinput.4.6.5-300.fc24.x86_64
Virtual core pointer                        id=2    [master pointer  (3)]
Virtual core XTEST pointer                    id=4    [slave  pointer  (2)]
ImExPS/2 BYD TouchPad                         id=11   [slave  pointer  (2)]

Comment 4 Bhaskar S. Manda 2016-09-05 15:40:00 UTC
The problem is still present in 4.7.2-201.fc24.x86_64.

Looking in /boot/config, it appears that in /boot/config/<kernel_version>, whenever,
CONFIG_MOUSE_PS2_BYD=y
is present, then the touchpad doesn't work correctly. In xinput, the ImExPS/2 BYD driver is used instead of the correct Sentelic driver.

I'm looking for how to switch drivers, but there is a lot of obsolete info on this out there.

Comment 5 Bhaskar S. Manda 2016-09-05 15:40:26 UTC
The problem is still present in 4.7.2-201.fc24.x86_64.

Looking in /boot/config, it appears that in /boot/config/<kernel_version>, whenever,
CONFIG_MOUSE_PS2_BYD=y
is present, then the touchpad doesn't work correctly. In xinput, the ImExPS/2 BYD driver is used instead of the correct Sentelic driver.

I'm looking for how to switch drivers, but there is a lot of obsolete info on this out there.

Comment 6 Bob M 2017-01-21 04:21:12 UTC
Any progress or fix? I'm running kernel 4.8.16 on an HP laptop and my touch pad has not been working for months.

If I load another distribution from a USB (e.g., CENTOS) touch pad works fine.

Comment 7 Bhaskar S. Manda 2017-02-25 02:47:06 UTC
It is fixed in the following kernels.
4.9.8-100
4.9.10-100