Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1354606

Summary: Minor (non-fatal) errors
Product: [Fedora] Fedora Reporter: Peter Trenholme <PTrenholme>
Component: system-config-printerAssignee: Zdenek Dohnal <zdohnal>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: unspecified    
Version: 25CC: jpopelka, twaugh, zdohnal
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: system-config-printer-1.5.7-10.fc25 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-10-26 22:30:18 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Peter Trenholme 2016-07-11 16:59:45 UTC
Description of problem: When run from a command prompt minor errors are reported.

Version-Release number of selected component (if applicable): Latest F-24

How reproducible: Every time

Steps to Reproduce: Start system-config-printer from a command prompt.

Actual results: See below.

Expected results: No warnings or errors displayed

Additional info:
$ sudo system-config-printer 
/usr/share/system-config-printer/system-config-printer.py:31: PyGIWarning: Polkit was imported without specifying a version first. Use gi.require_version('Polkit', '1.0') before import to ensure that the right version gets loaded.
  from gi.repository import Polkit
/usr/share/system-config-printer/system-config-printer.py:35: PyGIWarning: GdkPixbuf was imported without specifying a version first. Use gi.require_version('GdkPixbuf', '2.0') before import to ensure that the right version gets loaded.
  from gi.repository import GdkPixbuf
/usr/share/system-config-printer/system-config-printer.py:37: PyGIWarning: Gdk was imported without specifying a version first. Use gi.require_version('Gdk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gdk
/usr/share/system-config-printer/system-config-printer.py:38: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk
/usr/share/system-config-printer/jobviewer.py:28: PyGIWarning: Notify was imported without specifying a version first. Use gi.require_version('Notify', '0.7') before import to ensure that the right version gets loaded.
  from gi.repository import Notify
/usr/share/system-config-printer/jobviewer.py:55: PyGIWarning: GnomeKeyring was imported without specifying a version first. Use gi.require_version('GnomeKeyring', '1.0') before import to ensure that the right version gets loaded.
  from gi.repository import GnomeKeyring

Caught non-fatal exception.  Traceback:
File "/usr/share/system-config-printer/newprinter.py", line 1671, in setNPButtons
    uri = self.getDeviceURI ()
File "/usr/share/system-config-printer/newprinter.py", line 3221, in getDeviceURI
    type = self.device.type
AttributeError: 'NoneType' object has no attribute 'type'
Continuing anyway..

Comment 1 Jiri Popelka 2016-07-12 15:44:49 UTC
(In reply to Peter Trenholme from comment #0)
> PyGIWarning: Polkit was imported without specifying a version first. Use
> gi.require_version('Polkit', '1.0') before import to ensure that the right
> version gets loaded.
> ...

Already fixed upstream:
https://github.com/twaugh/system-config-printer/commit/5b4785782d75e45efde182d1c07d25ddd9c03eb3

> Caught non-fatal exception.  Traceback:
> File "/usr/share/system-config-printer/newprinter.py", line 1671, in
> setNPButtons
>     uri = self.getDeviceURI ()
> File "/usr/share/system-config-printer/newprinter.py", line 3221, in
> getDeviceURI
>     type = self.device.type
> AttributeError: 'NoneType' object has no attribute 'type'
> Continuing anyway..

Looks similar to bug #618640

Comment 2 Jiri Popelka 2016-10-12 07:00:17 UTC
*** Bug 1383869 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2016-10-26 04:25:03 UTC
system-config-printer-1.5.7-10.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-96e780df17

Comment 4 Fedora Update System 2016-10-26 22:30:18 UTC
system-config-printer-1.5.7-10.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.