Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1354584

Summary: Loop login after upgrade from F23 to F24
Product: [Fedora] Fedora Reporter: Andres Castillo <apavia95>
Component: xorg-x11-drv-intelAssignee: Adam Jackson <ajax>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 24CC: airlied, ajax, hdegoede, xgl-maint
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-07-12 19:26:32 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Andres Castillo 2016-07-11 15:56:23 UTC
Description of problem:

I've just updated my XPS 13 (intel graphics drivers Skylake) from F23 to F24

Once the system reboot, I was not able to login in the system using Gnome. The system send me back to login screen (loop) again and again. 

I've realized I can login using Mayland ... so maybe the problem is Gnome.


Error found is 

No screen found ...
 
Version-Release number of selected component (if applicable):

F24

How reproducible:
upgrade system

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Dell XPS 13 i7
Skylake intel drivers

Comment 1 Dave Airlie 2016-07-11 21:46:06 UTC
can you provide the full Xorg log from when it dies?

Comment 2 Andres Castillo 2016-07-12 13:45:55 UTC
Thank you for your fast answer..

Here is my Xorg file

[    31.967] (--) Log file renamed from "/home/acastillo/.local/share/xorg/Xorg.pid-2878.log" to "/home/acastillo/.local/share/xorg/Xorg.0.log"
[    31.967] 
X.Org X Server 1.18.3
Release Date: 2016-04-04
[    31.967] X Protocol Version 11, Revision 0
[    31.967] Build Operating System:  4.4.9-300.fc23.x86_64 
[    31.967] Current Operating System: Linux puma 4.6.3-300.fc24.x86_64 #1 SMP Fri Jun 24 20:52:41 UTC 2016 x86_64
[    31.967] Kernel command line: BOOT_IMAGE=/vmlinuz-4.6.3-300.fc24.x86_64 root=/dev/mapper/fedora-root ro rd.lvm.lv=fedora/root rd.lvm.lv=fedora/swap rhgb quiet LANG=en_CA.UTF-8
[    31.967] Build Date: 28 June 2016  02:29:25AM
[    31.967] Build ID: xorg-x11-server 1.18.3-5.fc24 
[    31.967] Current version of pixman: 0.34.0
[    31.967] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[    31.967] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    31.967] (==) Log file: "/home/acastillo/.local/share/xorg/Xorg.0.log", Time: Tue Jul 12 09:14:36 2016
[    31.968] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    31.968] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    31.968] (==) No Layout section.  Using the first Screen section.
[    31.968] (==) No screen section available. Using defaults.
[    31.968] (**) |-->Screen "Default Screen Section" (0)
[    31.968] (**) |   |-->Monitor "<default monitor>"
[    31.968] (==) No device specified for screen "Default Screen Section".
	Using the first device section listed.
[    31.968] (**) |   |-->Device "Intel Graphics"
[    31.968] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[    31.968] (==) Automatically adding devices
[    31.968] (==) Automatically enabling devices
[    31.968] (==) Automatically adding GPU devices
[    31.968] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    31.968] (==) FontPath set to:
	catalogue:/etc/X11/fontpath.d,
	built-ins
[    31.968] (==) ModulePath set to "/usr/lib64/xorg/modules"
[    31.968] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[    31.968] (II) Loader magic: 0x824dc0
[    31.968] (II) Module ABI versions:
[    31.968] 	X.Org ANSI C Emulation: 0.4
[    31.968] 	X.Org Video Driver: 20.0
[    31.968] 	X.Org XInput driver : 22.1
[    31.968] 	X.Org Server Extension : 9.0
[    31.969] (++) using VT number 2

[    31.971] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_32
[    31.971] (II) xfree86: Adding drm device (/dev/dri/card0)
[    31.971] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 9 paused 0
[    32.185] (--) PCI:*(0:0:2:0) 8086:1916:1028:0704 rev 7, Mem @ 0xdb000000/16777216, 0x90000000/268435456, I/O @ 0x0000f000/64, BIOS @ 0x????????/65536
[    32.186] (II) LoadModule: "glx"
[    32.186] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[    32.190] (II) Module glx: vendor="X.Org Foundation"
[    32.190] 	compiled for 1.18.3, module version = 1.0.0
[    32.190] 	ABI class: X.Org Server Extension, version 9.0
[    32.190] (==) AIGLX enabled
[    32.190] (II) LoadModule: "intel"
[    32.190] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
[    32.191] (II) Module intel: vendor="X.Org Foundation"
[    32.191] 	compiled for 1.18.3, module version = 2.99.917
[    32.191] 	Module class: X.Org Video Driver
[    32.191] 	ABI class: X.Org Video Driver, version 20.0
[    32.191] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
	i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
	915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
	Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
	GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[    32.191] (II) intel: Driver for Intel(R) HD Graphics: 2000-6000
[    32.191] (II) intel: Driver for Intel(R) Iris(TM) Graphics: 5100, 6100
[    32.191] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics: 5200, 6200, P6300
[    32.192] (EE) No devices detected.
[    32.192] (EE) 
Fatal server error:
[    32.192] (EE) no screens found(EE) 
[    32.192] (EE) 
Please consult the Fedora Project support 
	 at http://wiki.x.org
 for help. 
[    32.192] (EE) Please also check the log file at "/home/acastillo/.local/share/xorg/Xorg.0.log" for additional information.
[    32.192] (EE)

Comment 3 Hans de Goede 2016-07-12 16:49:23 UTC
It looks like you're missing the modesetting driver, try booting in text mode and then: "dnf install xorg-x11-drv-modesetting".

Comment 4 Andres Castillo 2016-07-12 18:38:22 UTC
Hi,
I have already installed the package xorg-x11-drv-modesetting.

I've realized the login page works fine when I use Gnome Wayland

or
 
when I use Gnome and remove the file 

/etc/X11/xorg.conf.d/20-intel.conf

This file has the settings for xorg...


Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "AccelMethod"            "sna" #set to glamor or uxa if unstable [sna,glamor,uxa]
    #Option      "ReprobeOutputs"       "true"
    Option      "SwapbuffersWait"        "true"
    Option      "DRI"                    "3"
    Option      "TearFree"               "true"
    Option      "Backlight"              "intel_backlight"

Comment 5 Hans de Goede 2016-07-12 19:26:32 UTC
Hi,

(In reply to Andres Castillo from comment #4)
> Hi,
> I have already installed the package xorg-x11-drv-modesetting.
> 
> I've realized the login page works fine when I use Gnome Wayland
> 
> or
>  
> when I use Gnome and remove the file 
> 
> /etc/X11/xorg.conf.d/20-intel.conf
> 
> This file has the settings for xorg...
> 
> 
> Identifier  "Intel Graphics"
>     Driver      "intel"
>     Option      "AccelMethod"            "sna" #set to glamor or uxa if
> unstable [sna,glamor,uxa]
>     #Option      "ReprobeOutputs"       "true"
>     Option      "SwapbuffersWait"        "true"
>     Option      "DRI"                    "3"
>     Option      "TearFree"               "true"
>     Option      "Backlight"              "intel_backlight"

Ah yes that is not a file installed by Fedora and that forces usage of the intel driver which does not seem to be a compatible with your hardware.

Since dropping the config file fixes things and since this file is not installed by Fedora I'm going to close this.

Comment 6 Andres Castillo 2016-07-13 13:27:05 UTC
Thank you for your help.

I want just remark the xorg file was created by Fedora 24 not for me. I didn't ave it when I had Fedora 23.