Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1354011

Summary: [RFE] UI: Workflow
Product: Red Hat OpenStack Reporter: Loic Avenel <lavenel>
Component: openstack-tripleo-uiAssignee: Jason E. Rist <jrist>
Status: CLOSED ERRATA QA Contact: Ola Pavlenko <opavlenk>
Severity: high Docs Contact:
Priority: high    
Version: 10.0 (Newton)CC: achernet, apannu, dbecker, dtrainor, jjoyce, jrist, jschluet, mburns, morazi, rhel-osp-director-maint, sclewis, slinaber, tvignaud, ukalifon
Target Milestone: gaKeywords: FutureFeature, Triaged
Target Release: 10.0 (Newton)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-tripleo-ui-1.0.1-0.20160907160155.3709e76.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-12-14 15:44:55 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1353793    

Description Loic Avenel 2016-07-08 17:07:12 UTC
OSP-d Workflow is visible on the main UI with clear 1,2,3 steps. Clear information are about each steps is visible by user to better understand what is currently expected at each steps. Terminology like "Deployment Plans" can be explained if user put his mouse over.

UX proposal:
https://openstack.invisionapp.com/share/247VLM4SB#/screens/164572227

Comment 4 Udi 2016-11-07 11:29:24 UTC
According to the UX proposal https://openstack.invisionapp.com/share/247VLM4SB#/screens/164572227, there should have been explanations to terminologies and items in the workflow if the user hovers with the mouse over them. This was not implemented, should we fail the bug or approve it as is?

Comment 5 Ola Pavlenko 2016-11-17 10:43:20 UTC
(In reply to Udi from comment #4)
> According to the UX proposal
> https://openstack.invisionapp.com/share/247VLM4SB#/screens/164572227, there
> should have been explanations to terminologies and items in the workflow if
> the user hovers with the mouse over them. This was not implemented, should
> we fail the bug or approve it as is?

Udi

Please submit a separate bug for the issue and add it to "Depends on" in the RFE.
If the bug is blocker, the RFE won't be verified until bug resolution.
RFE by definition, cannot be failed.

Comment 6 Udi 2016-11-17 11:29:24 UTC
Opened a bug on the unimplemented tooltips: https://bugzilla.redhat.com/show_bug.cgi?id=1396061

Comment 8 Dan Trainor 2016-12-09 20:34:15 UTC
Verified that the workflow is visible on the main UI with clear 1,2,3 steps.

Comment 10 errata-xmlrpc 2016-12-14 15:44:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html