Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1332

Summary: Limit on size of root partition makes installation difficult
Product: [Retired] Red Hat Linux Reporter: Pete Chown <2>
Component: distributionAssignee: Cristian Gafton <gafton>
Status: CLOSED NOTABUG QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-03-01 17:17:21 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Pete Chown 1999-02-25 17:44:43 UTC
There is a limit on the size of the root partition.  Now,
this makes sense in one way because it avoids the issue
where Lilo can't read the kernel because it is beyond the
area of the disk which is accessible by the BIOS.

However, it is possible to create a big root partition but
have a small partition mounted on /boot.  The new
installation system stops you doing this.

I am aware that this is a somewhat debatable point, so I
will raise it on the list as well.  I for one, though, will
find it very annoying if it gets into the final product.
(If you do decide to put it in, it would be nice to have a
way of overriding it, for example by stopping it applying to
expert mode installations.)

Comment 1 Dale Lovelace 1999-03-01 17:17:59 UTC
Disk Druid merely throws out a warning. It allows you to do this, but
you must later put in a smaller /boot partition. The documentation
(and possibly the disk druid warning) could be a little better here
though.