Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1305950

Summary: Fix name collision on MIPS
Product: [Fedora] Fedora Reporter: Michal Toman <michal.toman>
Component: libsrtpAssignee: Tom "spot" Callaway <tcallawa>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: jeff, tcallawa
Target Milestone: ---   
Target Release: ---   
Hardware: mips64   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-02-11 20:31:59 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1242747    
Attachments:
Description Flags
Fix-name-collision-on-MIPS.patch none

Description Michal Toman 2016-02-09 16:28:32 UTC
Created attachment 1122448 [details]
Fix-name-collision-on-MIPS.patch

Description of problem:
We are trying to bring Fedora to MIPS platform and this requires libsrtp renaming the 'mips' variable in test/srtp_driver.c - 'mips' is a predefined macro on MIPS platform.

Actual results:
Build fails because of 'mips' variable name collision

Expected results:
Build passes, variable named 'mips'

Additional info:
Attaching dist-git patch

Comment 1 Tom "spot" Callaway 2016-02-11 20:31:59 UTC
Thanks. Committed in libsrtp-1.5.4-1.fc24.