Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1299

Summary: LILO boots without SCSI
Product: [Retired] Red Hat Linux Reporter: steve.mckoy
Component: installerAssignee: David Lawrence <dkl>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.2   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-03-14 21:51:38 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description steve.mckoy 1999-02-23 16:48:06 UTC
After installing 5.2, I can boot LINUX from the startup
floppy and see the SCSI initialization cranking in and when
it gets all the way up, I can do a mount to the CDROM with
no problem.  However, if I boot to DOS and start LINUX with
LILO, I don't see the SCSI startup stuff and thus can't use
my cdrom.  I don't know what is the difference between the
two initializations and where to look to try to add the
scsi initialization to the LILO startup.  I need to keep a
dual-environment in which I can boot Windows 95 or LINUX.
I tried getting an answer on this with bug 1053, but I only
got one reply back.  I tried several attempts at building a
new kernel and nothing changes.  I am new to LINUX - that's
why I bought the book, to learn it - so I need to know
what's up with the two different initializations.  How do I
make the LILO come up the same way as the floppy boot?
Thanks in advance.

Comment 1 David Lawrence 1999-03-14 21:51:59 UTC
When booting to dos prior to starting linux, you need to use the
linload.exe utility (found on the Red Hat CD) to boot Linux, not LILO.
Also in order to get scsi support his way, you need to add an argument
to the linload.exe in the form of:

linload.exe vmlinuz root=/dev/hda3 init=/boot/initrd-2.0.36-0.7.img

Of course somethings such as the root argument and the version number
in the initrd may be different depending on your system.