Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1282

Summary: Boot.img bad, can't complete a install.
Product: [Retired] Red Hat Linux Reporter: Ray Curtis <ray>
Component: distributionAssignee: Matt Wilson <msw>
Severity: high Docs Contact:
Priority: high    
Version: 6.0CC: ray
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-03-13 21:14:10 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Ray Curtis 1999-02-22 19:16:21 UTC
System i386/scsi cdrom/ide harddrive

I just got the latest boot.img dated Feb. 19, and tried
using it to do a install using a scsi cdrom and an IDE

Looks like it was built incorrectly, I can get thru the
install procedure until I get to the Install Bootloader and
it fails.

I found it can't insmod loop.o with an error:
Kernel-module version mismatch
Loop.o was compiled for kernel version 2.2.1-ac3
while this kernel version is 2.2.1-4.

Comment 1 Dale Lovelace 1999-02-22 20:06:59 UTC
New boot images were put up 2/22/1999. These should correct this.

Comment 2 Ray Curtis 1999-02-22 21:18:59 UTC
Got the new boot.img dated Feb. 22 and  still the same problem:
fails at the Install Bootloader stage, so I go to a shell and try
insmod loop and get the error:

insmod loop.o:
	Kernel-module version mismatch
	loop.o was compiled for kernel version 2.2.1-ac3
	while this kernel version 2.2.1-6

Looks like the kernel has been updated but the loop module
remains at the same version as it was before.

Comment 3 Ray Curtis 1999-02-23 04:23:59 UTC
Tried the latest one tonight still no go. Dated:
 -rw-r--r--   2 root     root      1474560 Feb 22 17:45 boot.img

Comment 4 Matt Wilson 1999-03-13 21:14:59 UTC
You must have matching boot.img and install media.  The next snapshot
should fix everything.