Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1269964

Summary: Rebase clufter component [RHEL 6.8]
Product: Red Hat Enterprise Linux 6 Reporter: Jan Pokorný [poki] <jpokorny>
Component: clufterAssignee: Jan Pokorný [poki] <jpokorny>
Status: CLOSED ERRATA QA Contact: cluster-qe <cluster-qe>
Severity: medium Docs Contact:
Priority: high    
Version: 6.8CC: borgan, cfeist, cluster-qe, extras-qa, jpokorny, lkocman, lkuprova, mlisik, nobody, package-review, phagara, royoung, rsteiger, rwilliam, salmy, tlavigne, vpavlin
Target Milestone: rcKeywords: Rebase
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: clufter-0.56.2-1.el6 Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of: 1182358
: 1343661 (view as bug list) Environment:
Last Closed: 2016-05-10 19:28:14 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1182358, 1270740, 1272570, 1272592, 1300014, 1300050, 1319260    
Bug Blocks: 1264795, 1343661    

Description Jan Pokorný [poki] 2015-10-08 15:48:24 UTC
Upstream development of clufter has progressed (since 6.7 package till 7.2
package + something more likely to come) so this asks for a rebase.

More specifically, clufter received plentiful bug fixes and enhancements
compared to previous RHEL minor release (6.7/clufter-0.11.2-1.el6),
notably:

- configuration of bind-mount, nfsclient, SAPDatabase and SAPInstance
  rgmanager-compatible resource agents is now migrated in ccs2pcs
  command family
- ccs-/cib-/pcs-2pcscmd command families (modulo ccs-/pcs-2pcscmd-flatiron
  pre-existing commands) were added and allow one to produce a sequence
  of pcs commands to (re)instate the cluster configuration akin to the
  existing one as truly as possible
- ccs-disable-rg command was added to allow invocation separately
  from commands that call the underlying operation implicitly

Comment 2 Jan Pokorný [poki] 2015-11-05 20:30:12 UTC
Issue raised in [bug 1272570] has to be addressed for sure in this
rebase.

Comment 7 Jan Pokorný [poki] 2016-01-20 22:23:49 UTC
Will need to respin the package due to suboptimal integration with
pcs (as it passes unicode strings that wasn't previously expected)
and new related issue identified.

Comment 9 Miroslav Lisik 2016-03-16 17:37:49 UTC
We will need to respin the package due to validation issue.

[root@virt-010 ~]# clufter pcs2pcscmd
[ccspcmk2pcscmd     ] xslt: NOTE: cluster infrastructure services not enabled at this point, which can be changed any time by issuing `pcs cluster enable --all`
WARNING:clufter.format:Invalid as per RNG file `/usr/lib/python2.6/site-packages/clufter/formats/cib/pacemaker-2.4.rng'
WARNING:clufter.format:Invalid as per RNG file `/usr/lib/python2.6/site-packages/clufter/formats/cib/pacemaker-2.3.rng'
WARNING:clufter.format:Invalid as per RNG file `/usr/lib/python2.6/site-packages/clufter/formats/cib/pacemaker-2.0.rng'
WARNING:clufter.format:Invalid as per RNG file `/usr/lib/python2.6/site-packages/clufter/formats/cib/pacemaker-1.2.rng'
WARNING:clufter.format:None of the validation attempts succeeded with validator spec: /usr/lib/python2.6/site-packages/clufter/formats/cib/pacemaker-2.4.rng, /usr/lib/python2.6/site-packages/clufter/formats/cib/pacemaker-1.2.rng, /usr/lib/python2.6/site-packages/clufter/formats/cib/pacemaker-2.3.rng, /usr/lib/python2.6/site-packages/clufter/formats/cib/pacemaker-2.0.rng
cib: Validation: 1:0:Expecting an element status, got nothing, 1:0:Element cib failed to validate content
[root@virt-010 ~]# echo $?
1

By default, command generates list of pcs command from CIB of current cluster which is located at "/var/lib/pacemaker/cib/cib.xml".
An issue is that the file does not contain element status, which does not validate with RNG schema. When pacemaker stores CIB locally, it drops element status every time.

Comment 15 errata-xmlrpc 2016-05-10 19:28:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0740.html