Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1246

Summary: NFS installation fails
Product: [Retired] Red Hat Linux Reporter: Robert K. Moniot <moniot>
Component: installerAssignee: David Lawrence <dkl>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.2CC: moniot
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-03-02 23:24:17 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Robert K. Moniot 1999-02-19 18:08:10 UTC
Equipment: 486 33DX no-name clone, 8MB RAM, 500 MB IDE hard
drive, 3 1/2 (fd0) and 5 1/4 (fd1) floppy drives, Etherworks
3 NIC.  No CD or sound card.

Same behavior is observed with the original RH 5.2
installation diskette or the 1-Feb-1999 udated one.

Installation proceeds normally through selection of NFS for
the medium.   The RedHat CD is mounted on a remote host on
the same local network.  Choosing static IP addressing, I
define the local host IP to an available value and other
parameters appropriately.  (Note: using a rescue disk, I am
able to NFS mount the remote CD from this machine using the
same network parameters.)  I then specify the remote host IP
address and directory.  There is a pause, and then install
reports failure.  The following excerpts are my best effort
to copy the screen by hand.

On the install [F1] console, an Error box appears with the
message

   mount failed: Invalid argument

Below it, on the blue background window, is the message

   mount clntudp_create: RPC: Port mapper failure - RPC:
Timed out

On the [F3] console, I see everything OK up through the
"configuring
eth0" step, which is using the right values for everything.
Then I
see

* reverse name lookup failed
* running: /bin/insmod /bin/insmod /modules/nfs.o
* mounting 150.108.64.17:/cdrom on /tmp/rhimage as type nfs
* creating directory /tmp/rhimage rc = 0
* calling nfsmount(150.108.64.17:/cdrom, /tmp/rhimage,
&morejunk, &junk, &mount_opt)
*       nfsmount returned non-zero
* calling mount(150.108.64.17:/cdrom, /tmp/rhimage, nfs,
-1058209791, 0x80b4504)


On the [F4] console, I see, after the eth0 initialization,

<4>eth0: transmit timed/locked out, status 002d, resetting.
<4>eth0: transmit timed/locked out, status 002d, resetting.
<4>eth0: transmit timed/locked out, status 002d, resetting.
<4>nfs_read_super: not a socket
<4>ewrk3_queue_pkt(): No free resources...
<4>ewrk3_queue_pkt(): CSR: 25 ICR: c0 FMQC: 00
<4>eth0: transmit timed/locked out, status 0025, resetting.
<4>ewrk3_queue_pkt(): No free resources...
<4>ewrk3_queue_pkt(): CSR: 25 ICR: c0 FMQC: 00
<4>eth0: transmit timed/locked out, status 0025, resetting.
<4>eth0: transmit timed/locked out, status 002d, resetting.

Comment 1 David Lawrence 1999-03-02 23:24:59 UTC
Looks like a possible faulty network card. I would suggest trying
another card. Also make sure the settings that Linux is trying to use
are correct for your card.

------- Email Received From  Robert Moniot <moniot@pascal.dsm.fordham.edu> 03/03/99 10:50 -------