Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1241

Summary: Upgrade process results in a not-complete /usr/info/dir
Product: [Retired] Red Hat Linux Reporter: Chris Siebenmann <cks-rhbugzilla>
Component: textutilsAssignee: David Lawrence <dkl>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.2CC: cks-rhbugzilla
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-03-11 20:41:59 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Chris Siebenmann 1999-02-19 08:14:49 UTC
Upgrading a RedHat system from one RedHat release to
another (or, possibly, installing one to start with)
may result in a /usr/info/dir info dirfile that is not
complete.

 The basic problem is that /usr/info/dir is both a file
supplied by an RPM (from the info RPM) and a file built
dynamically from package %postinstall scripts running
/sbin/install-info. When a whole-system upgrade runs
and installs a new version of the info package, any
changes that %postinstall scripts have made get lost.
This means that any RPM that supplies its own info file
and is not upgraded in a whole-system upgrade may drop
out of the info file.

 Since some GNU packages are *only* documented by their
info files (having no manpages), I tend to think that
this is a reasonably bad thing.

 I think that the best solution is to not have the info
RPM supply a /usr/info/dir file at all. If the file is
going to contain important dynamically-installed stuff,
the entire file should be built dynamically; the info
RPM's %postinstall script can add the basic entries with
/sbin/install-info, just like everyone else.

(Possibly I am misreading the situation; it is hard to
tell with /usr/info/dir without exhaustive checking of
the contents against /usr/info/* entries.)

 The 'component' of this bug report is arbitrarily chosen
from the list of packages that run /sbin/install-info but
weren't said to be upgraded going from RedHat 5.1 to 5.2.
(I would use info itself as the component, but there is
no entry for it in the components dialog ... see my other
bug report on that.)

Comment 1 Jeff Johnson 1999-03-11 20:41:59 UTC
This problem will be fixed in Red Hat 6.0 by marking /usr/info/dir
as %config(norelace). That should result in the contents of
/usr/info/dir being preserved during upgrades.

Any package that supplies it's own /usr/info/dir is broke.