Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 121929

Summary: crystal icons for k-menu are missing
Product: [Fedora] Fedora Reporter: Gerald Teschl <gt>
Component: kdebaseAssignee: Petr Rockai <prockai>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 3CC: psimon, rdieter, than
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 3.3.2-0.8 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-02-22 15:43:23 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Gerald Teschl 2004-04-29 07:37:15 UTC
Description of problem:
After the upgrade from FC1 to FC2 I noted that the crystal
icons in my k-menu (for Accessories/Graphics/...) are
missing (they are replaced by some gnome icons). This
looks really ugly! Please fix.


Version-Release number of selected component (if applicable):
kdebase-3.2.2-1
kdelibs-3.2.2-3

Comment 1 Gerald Teschl 2004-06-03 09:34:07 UTC
Still here with kdebase-3.2.2-4 and kdelibs-3.2.2-6


Comment 2 Ngo Than 2004-06-04 11:02:45 UTC
i'm still working on it ;-)

Comment 3 Gerald Teschl 2004-07-26 14:14:53 UTC
I just looked at the differences between FC1 and FC2

KDE in FC1 (kdebase-3.2.2-0.1) does not use the redhat menues,
it uses the KDE-*.directory files.
KDE in FC2 uses the redhat *.directory files (and not the
kde-*.directory) files. Moreover, since the Redhat-*.icons
are not present in the crystal icon set, it uses those from
hicolor. Hoever, the new gnome-icon-theme installs everything into
/usr/share/icons/hicolor (rather than /usr/share/icons/gnome) and
hence kde picks those.




Comment 4 Gerald Teschl 2004-11-10 19:20:26 UTC
Still present in fc3 kde 3.3.1

Comment 6 Petr Rockai 2005-02-15 14:26:23 UTC
This is a somewhat more fundamental problem with fedora/rh settings in kde.  
Since the KDE menu is built from /etc/xdg/menus and there are no corresponding 
icons at all in crystal for the Icon=redhat-* entries, they are, as Gerald 
pointed out, substituted from bluecurve(?). The solution (which i will 
implement ASAP) is to symlink the appropriate crystal package_ icons into 
redhat- icons, so kiconloader can find those versions. 

Comment 8 Ngo Than 2005-02-15 15:22:01 UTC
yes, symlinking the appropriate crystal package icons into redhat icons
is a just a workaround. I think, a clean solution would be that we have to define
a common icon name for that or perhaps overtake the icon name from KDE.
Then changing the item "Icon=..." in all the desktop files in
/usr/share/desktop-directories/, add symlinks in bluecurve icons theme

Comment 10 Petr Rockai 2005-02-16 10:33:45 UTC
Ok, i looked into the issue some more. In bluecurve, the redhat-*.png icons are 
just symlinks to real icons as well, so adding similar symlinks to crystal 
shouldn't be a problem, really. What however is more of a problem is to find 
corresponding icons in crystal... Going to do so now. 

Comment 11 Petr Rockai 2005-02-22 15:43:23 UTC
Should be fixed. Please report omissions in a new bugreport if you still find     
some. Thanks.