Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 121451

Summary: [PATCH] authconfig settings disallow local logins when LDAP server unavailable
Product: Red Hat Enterprise Linux 3 Reporter: John Berninger <john>
Component: authconfigAssignee: Tomas Mraz <tmraz>
Status: CLOSED DUPLICATE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 3.0CC: nalin, pmatilai, sbonnevi, tao, tcallawa
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-12-15 12:32:14 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Patch to change behavior to server unavailability will allow local login none

Description John Berninger 2004-04-21 18:02:35 UTC
Description of problem:
LDAP logins configured, LDAP server unavailable (network issue), root
login disallowed.

Version-Release number of selected component (if applicable):
authconfig-4.3.7-1

How reproducible:
always

Steps to Reproduce:
1. Configure LDAP logins with authconfig
2. Take LDAP server down
3. Attempt local root login to client machine
  
Actual results:
Login failure

Expected results:
Login allowed

Additional info:

Comment 1 John Berninger 2004-04-21 18:04:25 UTC
Created attachment 99608 [details]
Patch to change behavior to server unavailability will allow local login

Comment 2 Steve Bonneville 2004-05-05 20:41:33 UTC
I think this is a duplicate of bug #121944, bug #100504, bug #55193,
and bug #53796.  Bug #86606 and bug #77575 (CLOSED DUPLICATE) are
related bugs, as well as bunches of others related to those, dating as
far back as Red Hat Linux 7.3 but still current.  


Comment 3 Jindrich Novy 2004-09-14 12:23:14 UTC

*** This bug has been marked as a duplicate of 121944 ***

Comment 4 Tomas Mraz 2004-12-07 12:24:29 UTC
I'll reopen this as the other duplicates are too cluttered.


Comment 5 Tomas Mraz 2004-12-07 12:29:35 UTC
The patch is legitimate approach to this problem, however it has the
problem of possibly allowing in users which weren't allowed in when
the auth server was available.

So either it must be configurable in the authconfig UI or it must be
done other way (probably somehow similarly to current FC3, RHEL4
solution).


Comment 6 Tomas Mraz 2004-12-15 12:31:13 UTC

*** This bug has been marked as a duplicate of 109359 ***