Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1183

Summary: Is this a bug in the install program?
Product: [Retired] Red Hat Linux Reporter: svalente
Component: installerAssignee: David Lawrence <dkl>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.2   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-03-12 22:21:36 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description svalente 1999-02-15 22:40:43 UTC
I noticed that, after an NFS install, the hostname in
/etc/sysconfig/network was always incorrectly set to
localhost.localdomain.  I assumed this was a bug and
decided to try to fix it.  I tracked the problem down to
this code in net.c:
    if (netc->manuallySet & NETINFO_HAS_HOSTNAME)
	fprintf(f, "HOSTNAME=%s\n", netc->hostname);
    else
	fprintf(f, "HOSTNAME=localhost.localdomain\n");

I don't know what to make of this.  I'm completely at a loss
for words.  I can't believe that it _is_ a bug, since the
code is explicitly written to avoid storing the hostname
in /etc/sysconfig/network when the hostname has been
reverse resolved (rather than manually entered.)  On the
other hand, I can't believe that it is _not_ a bug, since
it's so horribly wrong.

Well, you decide.

Comment 1 David Lawrence 1999-03-12 22:21:59 UTC
Normally hostname is set by either dhcp or you can set it manually
using netcfg after install.