Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1174

Summary: slocate RPM install broken, functionality broken
Product: [Retired] Red Hat Raw Hide Reporter: Preston Brown <pbrown>
Component: slocateAssignee: Bill Nottingham <notting>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 1.0CC: rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-02-15 17:55:05 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Preston Brown 1999-02-15 16:07:27 UTC
When I installed slocate, it couldn't find the user for many
of the files it wanted to install (slocate), and thus it
installed them with user root.  This is a packaging problem.

Probably because of this, when I try to run a locate on a
file as a normal user, I now get:

[pbrown@pip chkfontpath]$ locate glib
locate: decode_db(): open: (13) Permission denied

I'm fairly sure this is a result of the above though.

Comment 1 Bill Nottingham 1999-02-15 17:55:59 UTC
should be fixed in slocate-1.4-2
(%post groupadd moved to %pre)