Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 117169

Summary: Reload button doesn't work
Product: [Fedora] Fedora Reporter: Tethys <sta040>
Component: ggvAssignee: Ray Strode [halfline] <rstrode>
Status: CLOSED WONTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 1CC: bart.martens
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-09-09 19:58:10 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Tethys 2004-03-01 03:25:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624

Description of problem:
The reload button should reread the contents of the PostScript
file, and display the new contents. Instead, it just displays
the old contents.

Version-Release number of selected component (if applicable):
ggv-2.4.0.1-1

How reproducible:
Always

Steps to Reproduce:
1. Open a PostScript file
2. Modify the file
3. Click the reload button
    

Actual Results:  No change

Expected Results:  Display updated to reflect changes to file

Additional info:

This appears to be a duplicate of bug 77080. However, I can't reopen
that, so I'm having to log a new bug. It was apparently fixed in Rawhide
over a year ago, yet it's definitely present in FC1.

Comment 1 Bart Martens 2004-03-03 06:14:44 UTC

*** This bug has been marked as a duplicate of 77080 ***

Comment 2 Bart Martens 2004-03-03 21:58:17 UTC
Removing mark as duplicate, reopening.

Two others can't reproduce the problem with ggv-2.4.0.1-1. Tethys, can
you re-test please?


Comment 3 Tethys 2004-03-03 22:02:36 UTC
Yep, retested, definitely still a problem with ggv-2.4.0.1-1 on FC1

Comment 4 Bart Martens 2004-03-03 22:24:10 UTC
OK, here's how I tested this.

1. Install emacs-21.3-7 if you don't have it already
2. Make a copy of /usr/share/emacs/21.3/etc/refcard.ps
3. Open the copy in ggv, see the title "GNU Emacs Reference Card"
4. Open the copy in a good editor, like vi :-)
5. Modify the title, replace GNU by GUN, and save
6. Press the reload button in ggv
7. See the title "GUN Emacs Reference Card"
8. Optional: remove emacs-21.3-7 :-)

Can you try this? How did you test?


Comment 5 Roshan Sembacuttiaratchy 2004-03-08 16:35:07 UTC
I have tested this just now, and see that identical versions of GS and
GGV installed on my machine do not exhibit this reload bug, whereas my
friend's computer here next to me DOES exhibit it.  Both of us are
running freshly installed copies of Fedora Core 1, with the same apt
sources.list, both systems updated to the latest versions available
currently, and version strings for GS and GGV identical.  

I have not yet been able to identify a reason for one machine doing
the reload properly, and the other not.  

Performing testing by changing and recompiling a LaTeX document.  The
non-reloadable machine does show the file correctly if one quits and
restarts.  

Comment 6 Dan Williams 2004-11-17 18:23:38 UTC
Mass reassign to Marco.

Comment 7 Ray Strode [halfline] 2005-09-09 19:58:10 UTC
Hi guys,

We no longer support FC1 or ggv.  Have you heard of Evince?  It's a very good
postscript/pdf file viewer that we support.

Comment 8 Tethys 2005-09-12 15:08:08 UTC
Yeah, evince sucks compared to gv. It's slow and bloated. But that's what the
masses want, so I guess I'm headed back to the bad old days of comiling things
myself. I'm all for having a consistent user interface across apps, but not
at the expense of usability. Sadly I seem to be in the minority. Sigh...