Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1149

Summary: esd fails to start during Gnome/Enlightenment startup
Product: [Retired] Red Hat Linux Reporter: Chris Runge <crunge>
Component: esoundAssignee: Michael Fulbright <msf>
Status: CLOSED DEFERRED QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-03-18 15:59:19 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Chris Runge 1999-02-13 18:12:59 UTC
Red Hat 5.8 {beta 1)

I install the beta 1 with Gnome, create a normal user, login
as that user and do a startx.

Enlightenment and GNOME starts but there is no sound as the
esound daemon (esd)  has not started.  Trying to start this
daemon as the user gives an error; it must be started as
root.

(Note: prior to installing beta 1 and playing with Gnome and
Enlightenment esd started automatically without a problem)

Comment 1 Dale Lovelace 1999-02-23 19:33:59 UTC
/dev/dsp has permissions:

crw-------   1 root     root      14,   3 May  5  1998 /dev/dsp

so a normal user can't start ESD. Changing these to 666 fixes the
problem. Don't know how they should be by default.

Comment 2 Michael Fulbright 1999-03-18 15:59:59 UTC
This is due to a problem with the user console pam configuration
and the way gdm sets the DISPLAY variable.

This is being corrected.