Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1144

Summary: Don't clear the screen before first login
Product: [Retired] Red Hat Linux Reporter: Marc MERLIN <marc_soft>
Component: initscriptsAssignee: David Lawrence <dkl>
Status: CLOSED WONTFIX QA Contact:
Severity: low Docs Contact:
Priority: medium    
Version: 5.2CC: djr, notting
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-02-15 20:53:05 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Marc MERLIN 1999-02-13 08:25:54 UTC
In /etc/inittab:

 # Run gettys in standard
runlevels
-1:12345:respawn:/sbin/mingetty
tty1
+1:12345:respawn:/sbin/mingetty --noclear
tty1

Boot messages shouldn't disappear as soon as mingetty is
launched. It makes debugging the boot process really
difficult.

Comment 1 Marc MERLIN 1999-09-13 19:47:59 UTC
I just realized that no reason was ever given for the discard.
I'll respect your opinion, but since my request was reasonable, maybe
you can tell me why clearing boot messages right away is a good thing?

Comment 2 Bill Nottingham 1999-09-13 21:43:59 UTC
Consistency of display across all virtual terminals.
Less ugliness on the screen.
It's the way it's always been done. ;)

In any case, the boot messages are logged in 6.0+.

Comment 3 Bill Nottingham 2000-10-02 22:19:46 UTC
*** Bug 17854 has been marked as a duplicate of this bug. ***

Comment 4 Bill Nottingham 2001-07-06 02:30:46 UTC
*** Bug 47518 has been marked as a duplicate of this bug. ***

Comment 5 Bill Nottingham 2004-09-01 16:48:15 UTC
*** Bug 131463 has been marked as a duplicate of this bug. ***

Comment 6 Daniel Reed 2004-09-01 16:58:03 UTC
This may contribute to poor bug reports and general user frustration.
At worst, this should be controlled by some easy/obvious knob. (I was
not able to determine what was causing the screen to be cleared
without asking.)

Comment 7 Bill Nottingham 2005-02-15 20:53:05 UTC
Closing out bugs on older unsupported releases.

This has been this way for so long that I don't see it really changing. It's
certainly editable in inittab for those that want otherwise; keying inittab
information off of a separate configuration flag isn't really practical, and
won't make it much more user friendly.