Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1142436

Summary: Add sat5to6 and related RPMs to rhn-tools for release
Product: Red Hat Satellite 5 Reporter: Grant Gainey <ggainey>
Component: ClientAssignee: Grant Gainey <ggainey>
Status: CLOSED ERRATA QA Contact: Red Hat Satellite QA List <satellite-qa-list>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 560CC: awood, cperry, lpramuk, tlestach
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-10-07 14:00:41 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 924189    

Description Grant Gainey 2014-09-16 18:46:09 UTC
To get the client-side tooling for the Sat5-to-Sat6 transition-tooling into customer hands, release into the RHN Tools channel(s) until the next RHEL release-cycle comes around.

Comment 3 Lukas Pramuk 2014-10-06 11:55:45 UTC
VERIFIED.

sat5to6-1.0.1-2.el5
python-rhsm-1.13.2-1.el5
subscription-manager-1.11.3-11.el5
subscription-manager-migration-data-2.0.10-1.el5

sat5to6-1.0.1-2.el6.noarch
python-rhsm-1.13.2-1.el6.x86_64
subscription-manager-1.9.13-1.el6.x86_64
subscription-manager-migration-data-2.0.5-1.el6.noarch

sat5to6-1.0.1-2.el7.noarch
python-rhsm-1.13.2-1.el7.x86_64
subscription-manager-1.10.14-10.el7.x86_64
subscription-manager-migration-data-2.0.7-1.el7.noarch

# sat5to6 --registration-state=purge --legacy-user=<SAT5_ADMIN> --legacy-password=<SAT5_PASS> --destination-user=admin --destination-password=changeme
Unable to connect to certificate server: Invalid username or password. To create a login, please visit https://www.redhat.com/wapps/ugc/register.html.  See /var/log/rhsm/rhsm.log for more details.

>>> without ca certs installed no ugly traceback


# yum install katello-ca-consumer-latest.noarch.rpm --nogpgcheck
...

# sat5to6 --registration-state=purge --legacy-user=<SAT5_ADMIN> --legacy-password=<SAT5_PASS> --destination-user=admin --destination-password=changeme

Retrieving existing legacy subscription information...

+-----------------------------------------------------+
System is currently subscribed to these legacy channels:
+-----------------------------------------------------+
rhel-x86_64-server-5
rhn-tools-rhel-x86_64-server-5

+-----------------------------------------------------+
Installing product certificates for these legacy channels:
+-----------------------------------------------------+
rhel-x86_64-server-5
rhn-tools-rhel-x86_64-server-5

Product certificates installed successfully to /etc/pki/product.

Preparing to unregister system from legacy server...
System successfully unregistered from legacy server.

Attempting to register system to destination server...
The system has been registered with ID: 5d5cf38a-29d9-4333-99c7-7acf75a0c92e 
Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Server
Status:       Subscribed

System '<CLIENT_FQDN>' successfully registered.

>>> client checked-in on SAT6 side, on SAT5 side profile deleted


# sat5to6 --registration-state=keep --legacy-user=<SAT5_ADMIN> --legacy-password=<SAT5_PASS> --destination-user=admin --destination-password=changeme

Retrieving existing legacy subscription information...

+-----------------------------------------------------+
System is currently subscribed to these legacy channels:
+-----------------------------------------------------+
rhel-x86_64-server-7
rhn-tools-rhel-x86_64-server-7

+-----------------------------------------------------+
No product certificates are mapped to these legacy channels:
+-----------------------------------------------------+
rhn-tools-rhel-x86_64-server-7

+-----------------------------------------------------+
Installing product certificates for these legacy channels:
+-----------------------------------------------------+
rhel-x86_64-server-7

Product certificates installed successfully to /etc/pki/product.

Attempting to register system to destination server...
WARNING

This system has already been registered with Red Hat using RHN Classic.

Your system is being registered again using Red Hat Subscription Management. Red Hat recommends that customers only register once.

To learn how to unregister from either service please consult this Knowledge Base Article: https://access.redhat.com/kb/docs/DOC-45563
The system has been registered with ID: 164b3885-ae65-4b3e-a2d5-155f4d66f0ab 
Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Server
Status:       Subscribed

System 'URI:CN=<CLIENT_FQDN>' successfully registered.

>>> client checked-in on SAT6 side, on SAT5 side no changes done

# sat5to6 --registration-state=unentitle --legacy-user=<SAT5_ADMIN> --legacy-password=<SAT5_PASS> --destination-user=admin --destination-password=changeme
...

>>> client checked-in on SAT6 side, on SAT5 side profile unentitled


# sat5to6 --legacy-user=<SAT5_ADMIN> --legacy-password=<SAT5_PASS> --destination-user=admin --destination-password=changeme

This system appears to already be registered to Satellite 6.

>>> successive runs give up on re-registering

Comment 5 errata-xmlrpc 2014-10-07 14:00:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1364.html