Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1122867

Summary: Build fails with a dependency on iasl.
Product: [Fedora] Fedora Reporter: Éric Fintzel <efintzel>
Component: qemuAssignee: Fedora Virtualization Maintainers <virt-maint>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 21CC: amit.shah, berrange, cfergeau, dan, dwmw2, efintzel, itamar, pbonzini, rjones, scottt.tw, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: ppc64le   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-07-24 13:44:09 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1051573    
Attachments:
Description Flags
Patch applied to the qemu.spec file. none

Description Éric Fintzel 2014-07-24 09:08:19 UTC
Created attachment 920470 [details]
Patch applied to the qemu.spec file.

Description of problem:

The build fails due to an iasl dependency.


Version-Release number of selected component (if applicable):

qemu-2.1.0-0.4.rc2.fc22.src.rpm


How reproducible:

Mock build with make check active.


Actual results:

Dependency error in the root.log file:
...
DEBUG util.py:282:   --> qemu-sanity-check-nodeps-1.1.4-2.fc21.ppc64le
DEBUG util.py:282:   --> kernel-3.15.0-1.fc21.ppc64le
DEBUG util.py:282:  Error: No Package found for iasl
DEBUG util.py:372:  Child return code was: 1
DEBUG util.py:332:  Executing command: ['/bin/umount', '-n', '-l', '/var/lib/mock/f21-build-513966-386681/root/dev/pts'] with env {'LANG': 'en_US.UTF-8', 'TERM': 'vt100', 'SHELL': '/bin/bash', 'HOSTNAME': 'mock', 'HOME': '/builddir', 'PATH': '/usr/bin:/bin:/usr/sbin:/sbin'}
...


Additional info:

The build becomes successful when the iasl dependency is removed from the qemu.spec file.

FAILED - Task 1960678
ppc.koji.fedoraproject.org/koji/taskinfo?taskID=1960678

SUCCESS - Task 1960869
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=1960869

Comment 1 Dan Horák 2014-07-24 09:37:04 UTC
Should be just a matter of rebuilding acpica-tools so the result will include also ppc64le rpms.

Comment 2 Dan Horák 2014-07-24 10:47:25 UTC
Please try now, I've added the missing rpms and refreshed the repo.

Comment 3 Éric Fintzel 2014-07-24 13:44:09 UTC
Scratch build retry after your acpica-tools rebuild was successful, thanks.