Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1113453

Summary: Engine not free pending_vmem_size of host if vm started in paused mode
Product: Red Hat Enterprise Virtualization Manager Reporter: Artyom <alukiano>
Component: ovirt-engineAssignee: nobody nobody <nobody>
Status: CLOSED CURRENTRELEASE QA Contact: Artyom <alukiano>
Severity: urgent Docs Contact:
Priority: high    
Version: 3.3.0CC: dfediuck, gklein, iheim, jentrena, lpeer, mavital, ofrenkel, rbalakri, Rhev-m-bugs, sherold, s.kieske, yeylon
Target Milestone: ---Keywords: Reopened, TestOnly, Triaged
Target Release: 3.5.0   
Hardware: x86_64   
OS: Linux   
Whiteboard: sla
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-02-17 17:12:02 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: SLA RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1142923, 1156165    

Description Artyom 2014-06-26 08:30:14 UTC
Description of problem:
When I start vm in paused mode(not important via run once or just added flag via edit window) and after it stop vm(without start it) pending_vmem_size on host stay with value of vm memory guaranteed memory, if you again start vm in paused mode it will add another bunch of memory to this value(1024+1024), so you can reach state when you don't have running vms on host, but also can't start new vm because memory filter 

Version-Release number of selected component (if applicable):
av10

How reproducible:
always

Steps to Reproduce:
1. create new vm with some guaranteed memory(1024)
2. Run it in paused mode, wait until vm status paused, stop vm
3. Check pending_vmem_size of host, via engine database(select pending_vmem_size from vds_dynamic where vds_id='your_host_id';)

Actual results:
1024

Expected results:
0

Additional info:

Comment 1 Artyom 2014-06-26 10:34:03 UTC
The same thing happening when you migrate paused vm, so if you migrate vm from host to host you just increase pending_vmem_size parameter of each host

Comment 2 Omer Frenkel 2014-06-26 10:38:13 UTC
looks like a duplicate of bug 1049318 ? (or a 3.4 version of it)

Comment 3 Doron Fediuck 2014-06-30 14:09:58 UTC

*** This bug has been marked as a duplicate of bug 1049318 ***

Comment 7 Doron Fediuck 2014-09-15 14:30:49 UTC
This should be resolved by bug 1049318.
Please verify.

Comment 8 Artyom 2014-09-16 09:17:35 UTC
Verified vt3.1

Comment 9 Eyal Edri 2015-02-17 17:12:02 UTC
rhev 3.5.0 was released. closing.