Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 109708

Summary: Captial of Australia not listed
Product: [Fedora] Fedora Reporter: Mark Hulskamp <markh>
Component: tzdataAssignee: Jakub Jelinek <jakub>
Status: CLOSED WONTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 1Keywords: FutureFeature
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-10-06 19:34:06 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Mark Hulskamp 2003-11-11 04:39:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030 Epiphany/1.0.4

Description of problem:
Australia/Canberra is not display/able to be selected from the
map/location list
.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Redhat menu 
2. Systenm Settings
3. Date & Time
4. Click on "Time Zone Page"
5. Scrolllist doesnt present me with captial of Australia
    

Actual Results:  Captial city of my county is not listed

Expected Results:  To be able to select the captial city of my country

Additional info:

Comment 1 Need Real Name 2003-11-12 04:32:12 UTC
Not only is Canberra missing, so is the entire territory it's in :)

Comment 2 Tom Tromey 2003-11-19 07:55:48 UTC
In honor of bug day, I looked into this.

The problem occurs because neither Australia/Canberra
nor Australia/ACT appear in /usr/share/zoneinfo/zone.tab.
It's unclear whether this is intentional; looking in
/usr/share/zoneinfo/Australia, I notice that the rules
for Canberra and ACT are the same as the rule for Sydney.

I sent email to Paul Eggert to see if he could shed light on
this.  I'll update the PR if I find anything out.

I looked upstream a bit; this situation still holds in the
cvs glibc.


Comment 3 Brent Fox 2003-12-17 20:10:13 UTC
Changing component to tzdata.  There are numerous omissions from the
list of cities.  For instance, some major US population centers such
as Houston, Dallas, and St. Louis are not there as well.

Comment 4 Mark Hulskamp 2004-01-07 22:44:09 UTC
Interestingly, if you do a text mode install of Fedora,
Australia/Canberra is present as a timezone to select

Comment 5 Jakub Jelinek 2004-10-06 19:34:06 UTC
tzdata package will definitely not diverge from upstream, so if you
want to convince upstream how is Australia/Canberra different from
Australia/Sydney, go ahead, but AFAIK there is no difference.
tzdata doesn't list many cities, it picks just some city from
each timezone.