Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1095

Summary: Minor bug in function 'status' at /etc/rc.d/init.d/funtions
Product: [Retired] Red Hat Linux Reporter: ralcan
Component: initscriptsAssignee: David Lawrence <dkl>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.2CC: ralcan
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-02-10 15:20:27 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description ralcan 1999-02-10 11:06:58 UTC
When some of the programs at /etc/rc.d/init.d/ are called
with the 'status' parameter, sometimes they report an output
like this:
$ /etc/rc.d/init.d/sendmail status
sendmail (pid 1378
2011
2012) is running...
This is due to a bug in the 'status' function. The next
patch I submit removes this minor bug. BTW I hope you
release a new version of Red Hat Linux soon (I too use
2.2.1).
130c130
<                 pid=`ps auxww | grep '[^[]'$1 | awk
'{print $2}'`
---
>                 pid=`ps auxww | grep '[ ]'$1 | awk '{print
$2}'`
132c132,134
<                         echo "$1 (pid $pid) is running..."
---
>                         echo -n "$1 (pid "
>                       echo -n $pid
>                       echo    ") is running..."

Comment 1 Bill Nottingham 1999-02-10 15:20:59 UTC
this is fixed in a later initscripts package.