Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1092068

Summary: epel7 galera fails to build on secondary arches
Product: [Fedora] Fedora EPEL Reporter: Ryan O'Hara <rohara>
Component: galeraAssignee: Ryan O'Hara <rohara>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: epel7CC: bugproxy, dan, dhorak, hannsj_uhl, jcajka, rohara, social, yselkowi
Target Milestone: ---Keywords: Patch
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: galera-25.3.12-2.el7 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-06-07 04:20:12 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 238953, 1267648, 1285484, 1197165    

Description Ryan O'Hara 2014-04-28 16:28:07 UTC
galera fails to build on ppc64 due to lack of support for ppc64 in chromium/build_config.h.

Comment 1 Ryan O'Hara 2014-04-28 17:26:11 UTC
Note that I attempted to patch this by adding the following to chromium/build_config.h:

...
#elif defined(__PPC64__)
#define ARCH_CPU_64_BITS 1
#define ARCH_CPU_BIG_ENDIAN 1
...

While this clears up the previous compiler warnings, two of the tests fail.

Running suite(s): CRC32C implementation
0%: Checks: 2, Failures: 2, Errors: 0
galerautils/tests/gu_crc32c_test.c:56:F:test:test_software:0: Input '123456789' resulted in 0x10065321, expected 0xe3069283
galerautils/tests/gu_crc32c_test.c:56:F:test:test_hardware:0: Input '123456789' resulted in 0x10065321, expected 0xe3069283

Need to investigate further.

Comment 2 Jakub ńĆajka 2014-05-21 10:37:38 UTC
This also affects fedora package.

I posted link to this ticket upstream.
Upstream bug tracker ticket https://bugs.launchpad.net/galera/+bug/1257803.

Comment 3 Yaakov Selkowitz 2015-12-09 18:48:03 UTC
This is fixed in 25.3.12, but some arches require an additional patch due to -march=native.  Fedora 25.3.12-2 builds successfully on aarch64, ppc64*, and s390*:

http://arm.koji.fedoraproject.org/koji/buildinfo?buildID=328764
http://ppc.koji.fedoraproject.org/koji/buildinfo?buildID=353746
http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=2004118
http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=2004155

Please merge from master into epel7 and update.

Comment 4 Yaakov Selkowitz 2015-12-09 18:48:43 UTC
*** Bug 1269628 has been marked as a duplicate of this bug. ***

Comment 5 Yaakov Selkowitz 2016-04-28 01:55:10 UTC
Ryan,

Any objections to merging master into epel7 for the secondary arches?

Comment 6 Fedora Update System 2016-05-17 19:38:38 UTC
galera-25.3.12-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-c1f0e4564e

Comment 7 Fedora Update System 2016-05-21 06:23:03 UTC
galera-25.3.12-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-c1f0e4564e

Comment 8 Fedora Update System 2016-06-07 04:20:06 UTC
galera-25.3.12-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.