Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1086

Summary: No insmod avaliable on alpha install disks
Product: [Retired] Red Hat Linux Reporter: ejerde
Component: installerAssignee: Matt Wilson <msw>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.2   
Target Milestone: ---   
Target Release: ---   
Hardware: alpha   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-03-13 23:17:14 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description ejerde 1999-02-09 01:35:05 UTC
When attempting to install via ftp the dialogue for choosing
network cards appears, network card is selected, and then an
error dialogue pops up saying that "I cannot run
/bin/insmod: No such file or directory"  Suffice to say an
supposed install option is not really avaliable.

Comment 1 David Lawrence 1999-02-10 20:58:59 UTC
The kernel that comes on the Alpha does not support loadable modules.
The kernel is monolithic. We are working on making the kernel modular
on Alphas for the next release. This will alleviate the problem you
are experiencing.

Comment 2 ejerde 1999-02-10 21:34:59 UTC
So since the alpha kernel is monolithic does that mean I can't install
via ftp?  If this is the case why is it offered as an option by the
installer.

Comment 3 Matt Wilson 1999-03-13 21:22:59 UTC
Which kernel disk are you using and what type of ethernet card?

Comment 4 ejerde 1999-03-13 22:46:59 UTC
I am using noname.img and a 3com ultra elite isa card.Oops, that was a SMC, not 3com card.

Comment 5 Matt Wilson 1999-03-13 23:17:59 UTC
SMC cards are not supported by the noname.img.  The next version of
Red Hat Linux may support your network card.  You can try compiling
your own kernel on another alpha machine and copying it to the noname
floppy disk.