Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1074628

Summary: Unable to power on VM with attached OpenStack provider network
Product: Red Hat Enterprise Virtualization Manager Reporter: Brett Thurber <bthurber>
Component: rhev-hypervisorAssignee: Fabian Deutsch <fdeutsch>
Status: CLOSED DUPLICATE QA Contact: Pavel Stehlik <pstehlik>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 3.3.0CC: bthurber, dfediuck, gklein, iheim, lpeer, nyechiel, yeylon
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: network
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-04-24 09:06:54 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Network RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1077602    
Bug Blocks: 1099562    
Attachments:
Description Flags
RHEV-M provider network error.
none
RHEV-M engine.log
none
packstack answer file none

Description Brett Thurber 2014-03-10 17:12:51 UTC
Created attachment 872800 [details]
RHEV-M provider network error.

Description of problem:
Unable to power on a VM with a RHEL OSP prvider network attached to the VM.

Version-Release number of selected component (if applicable):
RHEV 3.3

How reproducible:
Every time

Steps to Reproduce:
1. Add a RHEL OSP provider
2. Import the RHEL OSP network
3. Attach a NIC to a VM and assign the provider network to the NIC.
4. Attempt to power on VM 

Actual results:
VM fails to power on.

Expected results:
VM power on and the provider network is assigned to an interface on the RHEV host.

Additional info:
Attached engine.log and screen shot.

Comment 1 Brett Thurber 2014-03-10 17:16:08 UTC
Created attachment 872802 [details]
RHEV-M engine.log

Comment 2 Doron Fediuck 2014-03-11 04:26:47 UTC
Hi Brett,
looking at your log I see the scheduler ruled out both rhev-h instances, since
they do not have access to a network which was marked as mandatory for the VM:

2014-03-08 02:12:52,337 INFO  [org.ovirt.engine.core.bll.scheduling.SchedulingManager] (ajp-/127.0.0.1:8702-3) [a777682] Candidate host cf-rhevh-2.xxx (c3b74227-80e8-40fd-a831-ae2f45a9b7f0) was filtered out by VAR__FILTERTYPE__INTERNAL filter Network
2014-03-08 02:12:52,338 INFO  [org.ovirt.engine.core.bll.scheduling.SchedulingManager] (ajp-/127.0.0.1:8702-3) [a777682] Candidate host cf-rhevh.xxx (15642662-fae2-4091-bbd5-7e12c79de993) was filtered out by VAR__FILTERTYPE__INTERNAL filter Network

I'd expect the same behaviour from a non-rhevh host, so it seems to me more related to the external provider implementation, than to rhev-h.
Can you reproduce it on a standard rhel host?

Comment 3 Brett Thurber 2014-03-11 15:35:03 UTC
Additional info on how the network is configured for the environment:

OpenStack , 3 nodes distributed (Glance, Neutron, Nova)
eth0 - management network (1GB BCOM NIC, vlan 162)
eth1 - external network (1GB BCOM NIC, vlan 162)
eth2 - reserved for iSCSI traffic to attach Cinder volumes (10GB Emulex NIC) 
eth3 - internal network (10GB Emulex NIC, internal vlans assigned via OpenStack)

RHEV, 2 RHEV-H hosts and 1 RHEV-M
RHEV-H
eth0 - iSCSI traffic (10GB Emulex NIC)
eth1 - not used (10GB Emulex NIC)
eth2 - rhevm (1GB BCOM NIC, vlan 162)
eth3 - up but unassigned (hoping the provider network would automatically attach to this NIC as the VM needs) (1GB BCOM NIC, vlan 162)

RHEV-M (virtual machine hosted on a RHEL KVM host)
eth0 - virtio 

I can add a RHEL host to RHEV but not sure that will resolve anything.  Documentation is sparse and not sure of dependencies and requirements.  If this information can be provided I can ensure those are met.  Also, I can provide access to my environment for debug/troubleshooting.

Comment 4 Brett Thurber 2014-03-11 15:36:24 UTC
Created attachment 873200 [details]
packstack answer file

Comment 5 Fabian Deutsch 2014-03-14 11:34:50 UTC
(In reply to Brett Thurber from comment #3)
...
> I can add a RHEL host to RHEV but not sure that will resolve anything. 

Yes, please do so.
It helps us to further isolate the problem. If this also happens with RHEL then it might be a different component having problems.

> Documentation is sparse and not sure of dependencies and requirements.  If
> this information can be provided I can ensure those are met.  Also, I can
> provide access to my environment for debug/troubleshooting.

Comment 6 Nir Yechiel 2014-03-19 12:28:28 UTC
Brett,

As Doron mentioned on comment #2 this could actually be a seperate issue.
That said, currently we do not support the RHEV-H build for integrating with Neutron, as the required neutron packages are just not there. I have filled this RFE [1] to further track it.

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1077602

Comment 7 Brett Thurber 2014-03-19 18:21:27 UTC
As-soon-as my environment resources become available I will install a RHEL hypervisor and test.  

Also, the limitation to the type of hypervisor supported needs to be added to the product docs.

Comment 8 Itamar Heim 2014-04-24 06:05:21 UTC
this sounds like 'notabug'.
nir/livnat - release notes around neutron in 3.3 were supposed to cover not available for rhev-h?

Comment 9 lpeer 2014-04-24 09:06:54 UTC
(In reply to Itamar Heim from comment #8)
> this sounds like 'notabug'.
> nir/livnat - release notes around neutron in 3.3 were supposed to cover not
> available for rhev-h?

I agree, we do not support external provider on rhev-h - yet, Nir added a link to the RHEV-h bug 1077602 - "Neutron Integration: Add support for RHEV-H based hosts"

The documentation states that this feature is not yet supported on RHEV-H, regardless Nir is working to improve the documentation of the integration for future versions.

*** This bug has been marked as a duplicate of bug 1077602 ***