Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1073340

Summary: traceback looking at system dashboard on a cleanly installed system
Product: Red Hat Enterprise Virtualization Manager Reporter: Sandro Bonazzola <sbonazzo>
Component: ovirt-engine-reportsAssignee: Yaniv Lavi <ylavi>
Status: CLOSED ERRATA QA Contact: movciari
Severity: high Docs Contact:
Priority: unspecified    
Version: 3.4.0CC: ecohen, gklein, iheim, movciari, pstehlik, rbalakri, Rhev-m-bugs, sradco, yeylon, ylavi
Target Milestone: ---   
Target Release: 3.5.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: infra
Fixed In Version: vt1.5 - rhevm-reports-3.5.0-1.el6_5 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-02-11 18:16:59 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Infra RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1142923, 1156165    
Attachments:
Description Flags
screenshot
none
logs
none
engine logs
none
all logs none

Description Sandro Bonazzola 2014-03-06 08:54:14 UTC
Just installed DWH and reports, no hosts added, no VM, no storage.
Looking at System Dashboard lead to the following trace.
100% reproducible. Datacenter Dashboard is not affected.



    Home

    Library

    View

    Manage

Search

    admin
    Log Out

System Dashboard

Page  

About JasperReports Server

Copyright © 2000-2013 Jaspersoft Corporation
Error Details
The server has encountered an error. Please excuse the inconvenience.
Error Message

net.sf.jasperreports.engine.JRRuntimeException: net.sf.jasperreports.engine.JRException: Error executing SQL statement for : system_storage_space_status_dr7
Error Trace

net.sf.jasperreports.engine.JRRuntimeException: net.sf.jasperreports.engine.JRException: Error executing SQL statement for : system_storage_space_status_dr7 at net.sf.jasperreports.engine.fill.JRFillSubreport.prepare(JRFillSubreport.java:782) at net.sf.jasperreports.engine.fill.JRFillElementContainer.prepareElements(JRFillElementContainer.java:331) at net.sf.jasperreports.engine.fill.JRFillBand.fill(JRFillBand.java:384) at net.sf.jasperreports.engine.fill.JRFillBand.fill(JRFillBand.java:358) at net.sf.jasperreports.engine.fill.JRVerticalFiller.fillSummaryNoLastFooterSamePage(JRVerticalFiller.java:1092) at net.sf.jasperreports.engine.fill.JRVerticalFiller.fillSummary(JRVerticalFiller.java:1055) at net.sf.jasperreports.engine.fill.JRVerticalFiller.fillReport(JRVerticalFiller.java:197) at net.sf.jasperreports.engine.fill.JRBaseFiller.fill(JRBaseFiller.java:932) at net.sf.jasperreports.engine.fill.BaseFillHandle$ReportFiller.run(BaseFillHandle.java:120) at com.jaspersoft.jasperserver.api.engine.jasperreports.service.impl.EngineServiceImpl$SynchronousExecutor.execute(EngineServiceImpl.java:880) at net.sf.jasperreports.engine.fill.BaseFillHandle.startFill(BaseFillHandle.java:165) at com.jaspersoft.jasperserver.api.engine.jasperreports.service.impl.EngineServiceImpl$AsynchronousReportFiller.fillReport(EngineServiceImpl.java:836) at com.jaspersoft.jasperserver.api.engine.jasperreports.service.impl.EngineServiceImpl.fillReport(EngineServiceImpl.java:1702) at com.jaspersoft.jasperserver.api.engine.jasperreports.service.impl.EngineServiceImpl$ReportFill.runWithDataSource(EngineServiceImpl.java:1057) at com.jaspersoft.jasperserver.api.engine.jasperreports.service.impl.EngineServiceImpl$ReportFill.runReport(EngineServiceImpl.java:991) at com.jaspersoft.jasperserver.api.engine.jasperreports.service.impl.EngineServiceImpl$ReportRunnable.run(EngineServiceImpl.java:902) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) at java.lang.Thread.run(Thread.java:744) Caused by: net.sf.jasperreports.engine.JRException: Error executing SQL statement for : system_storage_space_status_dr7 at net.sf.jasperreports.engine.query.JRJdbcQueryExecuter.createDatasource(JRJdbcQueryExecuter.java:240) at com.jaspersoft.jasperserver.api.engine.jasperreports.util.JRTimezoneJdbcQueryExecuter.createDatasource(JRTimezoneJdbcQueryExecuter.java:168) at net.sf.jasperreports.engine.fill.JRFillDataset.createQueryDatasource(JRFillDataset.java:1112) at net.sf.jasperreports.engine.fill.JRFillDataset.initDatasource(JRFillDataset.java:689) at net.sf.jasperreports.engine.fill.JRBaseFiller.setParameters(JRBaseFiller.java:1281) at net.sf.jasperreports.engine.fill.JRBaseFiller.fill(JRBaseFiller.java:900) at net.sf.jasperreports.engine.fill.JRBaseFiller.fill(JRBaseFiller.java:845) at net.sf.jasperreports.engine.fill.JRFillSubreport.fillSubreport(JRFillSubreport.java:651) at net.sf.jasperreports.engine.fill.JRSubreportRunnable.run(JRSubreportRunnable.java:59) at net.sf.jasperreports.engine.fill.AbstractThreadSubreportRunner.run(AbstractThreadSubreportRunner.java:203) ... 3 more Caused by: org.postgresql.util.PSQLException: ERRORE: divisione per zero at org.postgresql.core.v3.QueryExecutorImpl.receiveErrorResponse(QueryExecutorImpl.java:2157) at org.postgresql.core.v3.QueryExecutorImpl.processResults(QueryExecutorImpl.java:1886) at org.postgresql.core.v3.QueryExecutorImpl.execute(QueryExecutorImpl.java:255) at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:555) at org.postgresql.jdbc2.AbstractJdbc2Statement.executeWithFlags(AbstractJdbc2Statement.java:417) at org.postgresql.jdbc2.AbstractJdbc2Statement.executeQuery(AbstractJdbc2Statement.java:302) at org.apache.commons.dbcp.DelegatingPreparedStatement.executeQuery(DelegatingPreparedStatement.java:92) at net.sf.jasperreports.engine.query.JRJdbcQueryExecuter.createDatasource(JRJdbcQueryExecuter.java:233) ... 12 more
Error Message

net.sf.jasperreports.engine.JRException: Error executing SQL statement for : system_storage_space_status_dr7
Error Trace

net.sf.jasperreports.engine.JRException: Error executing SQL statement for : system_storage_space_status_dr7 at net.sf.jasperreports.engine.query.JRJdbcQueryExecuter.createDatasource(JRJdbcQueryExecuter.java:240) at com.jaspersoft.jasperserver.api.engine.jasperreports.util.JRTimezoneJdbcQueryExecuter.createDatasource(JRTimezoneJdbcQueryExecuter.java:168) at net.sf.jasperreports.engine.fill.JRFillDataset.createQueryDatasource(JRFillDataset.java:1112) at net.sf.jasperreports.engine.fill.JRFillDataset.initDatasource(JRFillDataset.java:689) at net.sf.jasperreports.engine.fill.JRBaseFiller.setParameters(JRBaseFiller.java:1281) at net.sf.jasperreports.engine.fill.JRBaseFiller.fill(JRBaseFiller.java:900) at net.sf.jasperreports.engine.fill.JRBaseFiller.fill(JRBaseFiller.java:845) at net.sf.jasperreports.engine.fill.JRFillSubreport.fillSubreport(JRFillSubreport.java:651) at net.sf.jasperreports.engine.fill.JRSubreportRunnable.run(JRSubreportRunnable.java:59) at net.sf.jasperreports.engine.fill.AbstractThreadSubreportRunner.run(AbstractThreadSubreportRunner.java:203) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) at java.lang.Thread.run(Thread.java:744) Caused by: org.postgresql.util.PSQLException: ERRORE: divisione per zero at org.postgresql.core.v3.QueryExecutorImpl.receiveErrorResponse(QueryExecutorImpl.java:2157) at org.postgresql.core.v3.QueryExecutorImpl.processResults(QueryExecutorImpl.java:1886) at org.postgresql.core.v3.QueryExecutorImpl.execute(QueryExecutorImpl.java:255) at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:555) at org.postgresql.jdbc2.AbstractJdbc2Statement.executeWithFlags(AbstractJdbc2Statement.java:417) at org.postgresql.jdbc2.AbstractJdbc2Statement.executeQuery(AbstractJdbc2Statement.java:302) at org.apache.commons.dbcp.DelegatingPreparedStatement.executeQuery(DelegatingPreparedStatement.java:92) at net.sf.jasperreports.engine.query.JRJdbcQueryExecuter.createDatasource(JRJdbcQueryExecuter.java:233) ... 12 more
Error Message

org.postgresql.util.PSQLException: ERRORE: divisione per zero
Error Trace

org.postgresql.util.PSQLException: ERRORE: divisione per zero at org.postgresql.core.v3.QueryExecutorImpl.receiveErrorResponse(QueryExecutorImpl.java:2157) at org.postgresql.core.v3.QueryExecutorImpl.processResults(QueryExecutorImpl.java:1886) at org.postgresql.core.v3.QueryExecutorImpl.execute(QueryExecutorImpl.java:255) at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:555) at org.postgresql.jdbc2.AbstractJdbc2Statement.executeWithFlags(AbstractJdbc2Statement.java:417) at org.postgresql.jdbc2.AbstractJdbc2Statement.executeQuery(AbstractJdbc2Statement.java:302) at org.apache.commons.dbcp.DelegatingPreparedStatement.executeQuery(DelegatingPreparedStatement.java:92) at net.sf.jasperreports.engine.query.JRJdbcQueryExecuter.createDatasource(JRJdbcQueryExecuter.java:233) at com.jaspersoft.jasperserver.api.engine.jasperreports.util.JRTimezoneJdbcQueryExecuter.createDatasource(JRTimezoneJdbcQueryExecuter.java:168) at net.sf.jasperreports.engine.fill.JRFillDataset.createQueryDatasource(JRFillDataset.java:1112) at net.sf.jasperreports.engine.fill.JRFillDataset.initDatasource(JRFillDataset.java:689) at net.sf.jasperreports.engine.fill.JRBaseFiller.setParameters(JRBaseFiller.java:1281) at net.sf.jasperreports.engine.fill.JRBaseFiller.fill(JRBaseFiller.java:900) at net.sf.jasperreports.engine.fill.JRBaseFiller.fill(JRBaseFiller.java:845) at net.sf.jasperreports.engine.fill.JRFillSubreport.fillSubreport(JRFillSubreport.java:651) at net.sf.jasperreports.engine.fill.JRSubreportRunnable.run(JRSubreportRunnable.java:59) at net.sf.jasperreports.engine.fill.AbstractThreadSubreportRunner.run(AbstractThreadSubreportRunner.java:203) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) at java.lang.Thread.run(Thread.java:744)

Comment 1 movciari 2014-07-30 11:26:57 UTC
now there's no traceback but there's no data either (i will add screenshot and logs)

Comment 2 movciari 2014-07-30 11:28:01 UTC
Created attachment 922489 [details]
screenshot

Comment 3 movciari 2014-07-30 11:28:39 UTC
Created attachment 922490 [details]
logs

Comment 4 Shirly Radco 2014-07-30 11:40:48 UTC
This should be tested in RHEV only because it is dashboards issues. Dasboards can be view only on RHEV.

Comment 5 Yaniv Lavi 2014-07-30 11:44:49 UTC
(In reply to Shirly Radco from comment #4)
> This should be tested in RHEV only because it is dashboards issues.
> Dasboards can be view only on RHEV.

It's a known issue that dashboards don't work in oVirt. We plan to fix this with JRS 5.6.0 since it's a Jasper issue.

Comment 7 movciari 2014-09-04 12:23:08 UTC
(In reply to Yaniv Dary from comment #5)
> (In reply to Shirly Radco from comment #4)
> > This should be tested in RHEV only because it is dashboards issues.
> > Dasboards can be view only on RHEV.
> 
> It's a known issue that dashboards don't work in oVirt. We plan to fix this
> with JRS 5.6.0 since it's a Jasper issue.

now i have the same issue in RHEVM vt2.1

Comment 8 Shirly Radco 2014-09-04 13:26:24 UTC
It will be fixed in vt3. Its a problem with the SSO.

Comment 10 movciari 2014-10-09 13:08:01 UTC
looking at system dashboard directly from reports portal works, but when looking at it from webadmin, dashboard is still empty like in screenshot from comment #2

Comment 11 Shirly Radco 2014-10-12 08:19:33 UTC
Can you please provide engine logs?

Comment 12 movciari 2014-10-13 14:26:56 UTC
Created attachment 946425 [details]
engine logs

Comment 13 Shirly Radco 2014-10-14 09:15:23 UTC
Michal,

Please add jasperserver logs as well.

This bug was caused due to system dashboard that did not load.
Please explain if only system dashboard or all dashboards are not loading.

Please make sure you wait a few seconds for the dashboards to load.
If all dashboards do not load please open a new bug and add it as dependent.

Comment 14 Shirly Radco 2014-10-14 09:16:56 UTC
Also please state on which environment did you test.

Comment 15 movciari 2014-10-14 16:02:31 UTC
there's only one dashboard tab in webadmin and it's empty... and i'm pretty sure i waited long enough
it's on rhel 6.6, engine, dwh, reports on same machine, build vt5
environment was already deleted, i'm posting logs from new environment

Comment 16 movciari 2014-10-14 16:03:05 UTC
Created attachment 946968 [details]
all logs

Comment 18 Shirly Radco 2014-10-19 11:39:45 UTC
I tried to reproduce, Dashboards are working for me in vt6.
Please make sure your hostname is set and fully qualified.

Comment 19 movciari 2014-10-21 10:46:58 UTC
it's a problem with firewall, not with hostname...
since there is a workaround for showing dashboard tab in webadmin and there is a bug for it ( https://bugzilla.redhat.com/show_bug.cgi?id=1155060 ), and dashboards work when accessed directly from reports portal, i will move this to verified

Comment 21 errata-xmlrpc 2015-02-11 18:16:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0176.html