Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1067255

Summary: SELinux is preventing /usr/bin/xinit from using the 'setpgid' accesses on a process.
Product: [Fedora] Fedora Reporter: Christopher Meng <i>
Component: selinux-policyAssignee: Miroslav Grepl <mgrepl>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: dominick.grift, dwalsh, lvrabec, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Unspecified   
Whiteboard: abrt_hash:1e0cc36b8bf6589e2332e7ff6dbe695a0fb72402a315cbc4ec2b9a73acdd0baa
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-02-20 09:21:54 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Christopher Meng 2014-02-20 03:06:34 UTC
Description of problem:
SELinux is preventing /usr/bin/xinit from using the 'setpgid' accesses on a process.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that xinit should be allowed setpgid access on processes labeled init_t by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep xinit /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:init_t:s0
Target Context                system_u:system_r:init_t:s0
Target Objects                 [ process ]
Source                        xinit
Source Path                   /usr/bin/xinit
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           xorg-x11-xinit-1.3.2-9.fc20.i686
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-25.fc21.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.14.0-0.rc2.git1.2.fc21.i686 #1
                              SMP Tue Feb 11 21:07:56 UTC 2014 i686 i686
Alert Count                   2
First Seen                    2014-02-20 11:00:53 CST
Last Seen                     2014-02-20 11:02:49 CST
Local ID                      2f9c0e9a-db2b-4f93-abe0-b12cee9f0662

Raw Audit Messages
type=AVC msg=audit(1392865369.192:31): avc:  denied  { setpgid } for  pid=577 comm="xinit" scontext=system_u:system_r:init_t:s0 tcontext=system_u:system_r:init_t:s0 tclass=process


type=SYSCALL msg=audit(1392865369.192:31): arch=i386 syscall=setpgid success=no exit=EACCES a0=0 a1=241 a2=804a700 a3=bf7ff728 items=0 ppid=563 pid=577 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=xinit exe=/usr/bin/xinit subj=system_u:system_r:init_t:s0 key=(null)

Hash: xinit,init_t,init_t,process,setpgid

Additional info:
reporter:       libreport-2.1.12
hashmarkername: setroubleshoot
kernel:         3.14.0-0.rc2.git1.2.fc21.i686
type:           libreport

Comment 1 Miroslav Grepl 2014-02-20 09:21:54 UTC

*** This bug has been marked as a duplicate of bug 1067254 ***