Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1066846

Summary: rhevm-dwh-setup failed with "FATAL: password authentication failed for user "engine_history"" error message.
Product: Red Hat Enterprise Virtualization Manager Reporter: Udayendu Sekhar Kar <ukar>
Component: ovirt-engine-dwhAssignee: Yedidyah Bar David <didi>
Status: CLOSED WONTFIX QA Contact: Barak Dagan <bdagan>
Severity: urgent Docs Contact:
Priority: urgent    
Version: 3.3.0CC: acathrow, gklein, iheim, oschreib, pstehlik, Rhev-m-bugs, rpai, yeylon
Target Milestone: ---   
Target Release: 3.3.2   
Hardware: x86_64   
OS: Linux   
Whiteboard: integration
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-02-20 12:57:47 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
rhevm dwh setp logs. none

Description Udayendu Sekhar Kar 2014-02-19 08:42:21 UTC
Description of problem:
While trying to do the rhevm-dwh-setup, it failed with the following error message:
----
2014-02-17 14:04:49::DEBUG::common_utils::907::root:: Executing command --> '/usr/share/ovirt-engine-dwh/db-scripts/upgrade.sh -s localhost -p 5432 -u engine_history -d ovirt_engine_history -l /var/log/ovirt-engine/ovirt-history-db-upgrade-2014_02_17_14_04_49.log -g' in working directory '/usr/share/ovirt-engine-dwh/db-scripts'
2014-02-17 14:04:49::DEBUG::common_utils::962::root:: output = 
2014-02-17 14:04:49::DEBUG::common_utils::963::root:: stderr = psql: FATAL:  password authentication failed for user "engine_history"
FATAL:  password authentication failed for user "engine_history"
----

Version-Release number of selected component (if applicable):
rhevm-dwh-3.3.0-29.el6ev.noarch
rhevm 3.3

How reproducible:
Not sure

Steps to Reproduce:
1.
2.
3.

Actual results:
failed to run 'rhevm-dwh-setup' successfully.

Expected results:
rhevm-dwh-setup should run successfully.

Comment 1 Udayendu Sekhar Kar 2014-02-19 08:43:11 UTC
Created attachment 865003 [details]
rhevm dwh setp logs.

Comment 4 Yedidyah Bar David 2014-02-20 12:57:23 UTC
The flow seems to have been, more-or-less:

1. engine-setup
2. Manually changing fqdn in /etc/ovirt-engine/engine.conf.d/10-setup-protocols.conf
3. rhevm-dwh-setup
4. rhevm-reports-setup
this one fails because it tries getting the ca cert from the fqdn in the protocols conf file
5. rhevm-reports-setup
another attempt fails with the message in the summary.

Closing, after helping GSS finding the root cause as detailed above, and with their agreement.

If you want any of these solved, please open a new bug with a clear explanation about what should be solved.