Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1066292

Summary: Error: Could not prefetch neutron_network provider 'neutron'
Product: [Fedora] Fedora Reporter: Frederic Hornain <fhornain>
Component: openstack-neutronAssignee: Terry Wilson <twilson>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 20CC: fhornain, jlibosva, rkukura, twilson
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-02-18 13:03:20 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Frederic Hornain 2014-02-18 08:35:21 UTC
Description of problem:

Well, I install a fresh Fedora 20. 
I followed the following documentation : http://openstack.redhat.com/Quickstart

[root@openstack ~]# packstack --allinone

X.X.X.X_swift.pp :                     [ DONE ]                   
                                                                                                 [ ERROR ]

ERROR : Error appeared during Puppet run: X.X.X.X_provision.pp
Error: Could not prefetch neutron_network provider 'neutron': Execution of '/usr/bin/neutron net-list --format=csv --column=id --quote=none' returned 1: Connection to neutron failed: Maximum attempts reached
You will find full trace in log /var/tmp/packstack/20140218-092122-UZP6Nx/manifests/X.X.X.X_provision.pp.log


[root@openstack ~]# cat /var/tmp/packstack/20140218-092122-UZP6Nx/manifests/X.X.X.X_provision.pp.log
connect: No such file or directory
Please make sure that the zfs-fuse daemon is running.
internal error: failed to initialize ZFS library
connect: No such file or directory
Please make sure that the zfs-fuse daemon is running.
internal error: failed to initialize ZFS library
Warning: Could not retrieve fact fqdn
Warning: Config file /etc/puppet/hiera.yaml not found, using Hiera defaults
Notice: Compiled catalog for openstack in environment production in 0.23 seconds
connect: No such file or directory
Please make sure that the zfs-fuse daemon is running.
internal error: failed to initialize ZFS library
connect: No such file or directory
Please make sure that the zfs-fuse daemon is running.
internal error: failed to initialize ZFS library
Notice: /Stage[main]/Openstack::Provision/Glance_image[cirros]/ensure: created
Error: Could not prefetch neutron_network provider 'neutron': Execution of '/usr/bin/neutron net-list --format=csv --column=id --quote=none' returned 1: Connection to neutron failed: Maximum attempts reached

Error: Execution of '/usr/bin/neutron net-create --format=shell --tenant_id=a8127aab58c74687947e62cc4278a06a --router:external=True public' returned 1: Connection to neutron failed: [Errno 111] Connection refused

Error: /Stage[main]/Openstack::Provision/Neutron_network[public]/ensure: change from absent to present failed: Execution of '/usr/bin/neutron net-create --format=shell --tenant_id=a8127aab58c74687947e62cc4278a06a --router:external=True public' returned 1: Connection to neutron failed: [Errno 111] Connection refused

Error: Could not prefetch neutron_subnet provider 'neutron': Execution of '/usr/bin/neutron subnet-list --format=csv --column=id --quote=none' returned 1: Connection to neutron failed: Maximum attempts reached

Notice: /Stage[main]/Openstack::Provision/Neutron_subnet[public_subnet]: Dependency Neutron_network[public] has failures: true
Warning: /Stage[main]/Openstack::Provision/Neutron_subnet[public_subnet]: Skipping because of failed dependencies
Notice: /Stage[main]/Openstack::Provision/Neutron_l3_ovs_bridge[br-ex]: Dependency Neutron_network[public] has failures: true
Warning: /Stage[main]/Openstack::Provision/Neutron_l3_ovs_bridge[br-ex]: Skipping because of failed dependencies
Error: Could not prefetch neutron_router provider 'neutron': Execution of '/usr/bin/neutron router-list --format=csv --column=id --quote=none' returned 1: Connection to neutron failed: Maximum attempts reached

Notice: /Stage[main]/Openstack::Provision/Neutron_router[router1]: Dependency Neutron_network[public] has failures: true
Warning: /Stage[main]/Openstack::Provision/Neutron_router[router1]: Skipping because of failed dependencies
Error: Execution of '/usr/bin/neutron net-create --format=shell --tenant_id=ae17de051aac4ac08fe3ce6825d54fc2 private' returned 1: Connection to neutron failed: [Errno 111] Connection refused

Error: /Stage[main]/Openstack::Provision/Neutron_network[private]/ensure: change from absent to present failed: Execution of '/usr/bin/neutron net-create --format=shell --tenant_id=ae17de051aac4ac08fe3ce6825d54fc2 private' returned 1: Connection to neutron failed: [Errno 111] Connection refused

Notice: /Stage[main]/Openstack::Provision/Neutron_subnet[private_subnet]: Dependency Neutron_network[private] has failures: true
Warning: /Stage[main]/Openstack::Provision/Neutron_subnet[private_subnet]: Skipping because of failed dependencies
Error: Could not prefetch neutron_router_interface provider 'neutron': Execution of '/usr/bin/neutron subnet-list --format=csv --column=id --quote=none' returned 1: Connection to neutron failed: Maximum attempts reached

Notice: /Stage[main]/Openstack::Provision/Neutron_router_interface[router1:private_subnet]: Dependency Neutron_network[public] has failures: true
Notice: /Stage[main]/Openstack::Provision/Neutron_router_interface[router1:private_subnet]: Dependency Neutron_network[private] has failures: true
Warning: /Stage[main]/Openstack::Provision/Neutron_router_interface[router1:private_subnet]: Skipping because of failed dependencies
Notice: Finished catalog run in 36.29 seconds

Comment 1 Jakub Libosvar 2014-02-18 12:18:31 UTC
Could you check /var/log/neutron/server.log? 
It seems like some service needed neutron API but it was not available. You can also check that neutron-server process is not running.

Comment 2 Frederic Hornain 2014-02-18 12:47:16 UTC
Well, I think you can close this case cause I add "HOSTNAME=myhost.myparentdomain" in the /etc/sysconfig/network as written in the enterprise Red hat Openshift "Getting Started Guide" documentation  - https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/ .
Then, I did an update of my Fedora 20 and did a restart.
Finally, I redid a packstat installation and did not have any error any more.

You can now close this ticket.

Thanks for your support and your time.

BR
/f

Comment 3 Jakub Libosvar 2014-02-18 13:03:20 UTC
Closing per comment 2