Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1066114

Summary: [RFE] Expand RHV's swap utilization metrics collection for reporting.
Product: Red Hat Enterprise Virtualization Manager Reporter: Matt Smith <mjs>
Component: RFEsAssignee: Shirly Radco <sradco>
Status: CLOSED ERRATA QA Contact: Lukas Svaty <lsvaty>
Severity: medium Docs Contact:
Priority: medium    
Version: 3.2.0CC: danken, eheftman, gklein, lbopf, lpeer, michal.skrivanek, mjs, pstehlik, rbalakri, rhodain, rmcswain, sradco, srevivo, ssekidde, ylavi
Target Milestone: ovirt-4.2.0Keywords: FutureFeature
Target Release: ---Flags: sherold: Triaged+
lsvaty: testing_plan_complete+
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
collectd's swap plugin has been expanded to provide the following swap statistics: used, free, cached, swap_io - in and swap_io out.
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-05-15 17:36:09 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Metrics RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Matt Smith 2014-02-17 17:58:39 UTC
1. Proposed title of this feature request  
Expand swap utilization metrics collection for reporting.
      
    3. What is the nature and description of the request?  
Provide swap utilization (throughput/latency) statistics (minimally swap-in and swap-out, as shown by vmstat), but ideally read/write totals and time for swap device too (as shown by iostat).
      
    4. Why does the customer need this? (List the business requirements here)  
* Customer is trying to understand total impact of memory overcommit in highly-dense RHEV VDI environment.  Watching output of vmstat is helpful in realtime, but goal is to report on swap usage over time, as workloads vary.
      
    5. How would the customer like to achieve this? (List the functional requirements here)
* Data should be collected and provided in ovirt_engine_history.
      
    6. For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.  
* Success is defined as being able to create an ad-hoc report that shows the swap-in/swap-out statistics over time.

    7. Is there already an existing RFE upstream or in Red Hat Bugzilla?  
* No
      
    8. Does the customer have any specific timeline dependencies and which release would they like to target (i.e. RHEL5, RHEL6)?  
* Ideally as an update to RHEV 3.3, but will accept whatever is possible.
      
    9. Is the sales team involved in this request and do they have any additional input?  
* Yes - this RFE is created by SA.
      
    10. List any affected packages or components.
* Unknown exactly where this needs to be implemented within RHEV
      
    11. Would the customer be able to assist in testing this functionality if implemented?  
* Yes

Comment 5 Scott Herold 2015-04-01 14:02:18 UTC
Removing from 3.6 due to capacity

Comment 7 Dan Kenigsberg 2015-05-12 09:17:13 UTC
Can you provide a more precise definition of the needed information? Is there a utility that provides it, which we can expose on our API?

Comment 8 Matt Smith 2015-05-26 00:12:37 UTC
Request is to capture swap activity as currently reported by vmstat (swap-in (si) and swap-out (so)) and iostat (tps, r/s, w/s, r, w).  These two tools are currently used to monitor swap activity in realtime, customer would like to record and track this data for reporting and analysis.

Comment 9 Michal Skrivanek 2015-06-05 12:13:38 UTC
This bug did not make it in time for 3.6 release, moving out

Comment 10 Robert McSwain 2016-03-23 13:41:54 UTC
Update from the customer with additional details for how they hope to use this reporting:

We will also need to be able to check the health of the system from these new metrics. Ideally, alerts should be sent if possible. Otherwise as a step by step process for interpreting the reports should be provided so IBM is able to determine when action is required,

Comment 11 Yaniv Kaul 2017-06-06 17:34:23 UTC
Shirly - can you provide a devel-ack for this for 4.2?

Comment 12 Shirly Radco 2017-07-18 06:19:01 UTC
The new metrics store should include these statistics.

Collectd provides
swap - used / free / cached
swap_io - in / out

Comment 13 Lukas Svaty 2017-10-04 14:24:14 UTC
Should this be considered also for VMs or only for hosts and engine machine?

Comment 14 Shirly Radco 2017-10-15 08:17:58 UTC
(In reply to Lukas Svaty from comment #13)
> Should this be considered also for VMs or only for hosts and engine machine?

Only hosts and engine machine.

Comment 16 Lukas Svaty 2017-12-14 16:29:40 UTC
collectd.plugin: swap
collectd.type_instance:
comparable to free -m | grep Swap
* used
* cached
* free
IO is reported (mostly 0, swapoff / swapon is causing is to rise as expected)
* out
* in 
collectd.swap.percent
collectd.swap.swap
collectd.swap.swap_io

available and correctly reported

verified in ovirt-engine-metrics-1.1.1-1.el7ev.noarch

Comment 19 errata-xmlrpc 2018-05-15 17:36:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1488