Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1065805

Summary: Thinkpad: Screen does not redirect to Dock
Product: [Fedora] Fedora Reporter: bjg
Component: xorg-x11Assignee: X/OpenGL Maintenance List <xgl-maint>
Status: CLOSED EOL QA Contact:
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 20   
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-06-29 15:15:10 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description bjg 2014-02-17 02:01:29 UTC
Description of problem:
FC20/Cinnamon system does not operate docked DVI monitors, either on boot-in-dock, or boot then insert to dock.  System is not crashed (not a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1036974).  I can SSH into host, and it will operate the LVDS1 fine if I remove from dock and open panel.

This system also has CentOS 6.5 (alternate drive), and the dock worked flawlessly.  This is a new problem with FC20/Cinnamon.

Note: The system was going to sleep when I closed the lid, even after setting power configuration to 'Do nothing' when lid is closed in all occasions.  I have since updated /etc/systemd/logind.conf to HandleLidSwitch=lock, so it does not sleep.

Version-Release number of selected component (if applicable):

Thinkpad W520
i915 integrated graphics (not nvidia discrete or optimus)
FC 20 with Cinnamon desktop

How reproducible:
Always.

Steps to Reproduce:
1.Close panel, insert into dock.
2.Screens do not switch.
3.Remove from dock, open panel.  System is functional.

Actual results:

Dock-connected displays do not initialize and operate.

Expected results:

Dock-connected displays should initialize and operate.

Additional info:

I tried switching to the discrete/nvidia akmod driver, loaded from rpmfusion, but that resulted in a kernel panic.

Comment 1 bjg 2014-02-18 15:51:39 UTC
Swapped hardware to identically configured w520.

1. NVidia driver works properly (originaly w520 likely has HW problem with nvidia).  Monitors switch on properly.
2. i915 intel driver still exhibits problem.  Appears to be specific to the i915 driver.

Comment 2 Fedora End Of Life 2015-05-29 10:56:51 UTC
This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 3 Fedora End Of Life 2015-06-29 15:15:10 UTC
Fedora 20 changed to end-of-life (EOL) status on 2015-06-23. Fedora 20 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.