Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1065730

Summary: [engine-setup] Cannot setup rhevm-dwh as it looks for upstream packages
Product: Red Hat Enterprise Virtualization Manager Reporter: Kiril Nesenko <knesenko>
Component: ovirt-engine-dwhAssignee: Yaniv Lavi <ylavi>
Status: CLOSED ERRATA QA Contact: Jiri Belka <jbelka>
Severity: high Docs Contact:
Priority: high    
Version: 3.4.0CC: acathrow, adahms, alonbl, dfediuck, eedri, gklein, iheim, jbelka, knesenko, lijli, lpeer, Rhev-m-bugs, scohen, yeylon, ylavi
Target Milestone: ---   
Target Release: 3.4.0   
Hardware: x86_64   
OS: Linux   
Whiteboard: integration
Fixed In Version: av3 - rhevm-dwh-setup-3.4.0-3.el6ev.noarch.rpm Doc Type: Bug Fix
Doc Text:
This update makes it possible to specify the packages used to install the Data Warehouse feature via the environment, ensuring that Red Hat Enterprise Virtualization does not attempt to use any packages from oVirt and making it possible to complete configuration of the Data Warehosue feature correctly.
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-06-09 15:18:17 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1057239, 1078909, 1142926    
Attachments:
Description Flags
setup_log
none
ovirt-engine-setup-$date.log(s) none

Description Kiril Nesenko 2014-02-16 12:46:43 UTC
Created attachment 863694 [details]
setup_log

Description of problem:
Trying to isntall rhevm-dwh fails with the following error.

[root@vm-37-137 ~]# engine-setup 
[ INFO  ] Stage: Initializing
[ INFO  ] Stage: Environment setup
          Configuration files: ['/etc/ovirt-engine-setup.conf.d/10-packaging.conf', '/etc/ovirt-engine-setup.conf.d/20-setup-ovirt-post.conf']
          Log file: /var/log/ovirt-engine/setup/ovirt-engine-setup-20140216144156.log
          Version: otopi-1.2.0_master (otopi-1.2.0-0.0.master.el6_5)
[ INFO  ] Stage: Environment packages setup
[ INFO  ] Stage: Programs detection
[ INFO  ] Stage: Environment setup
[ INFO  ] Stage: Environment customization
         
          --== PRODUCT OPTIONS ==--
         
          Install Data Warehouse on this host (Yes, No) [Yes]: 
         
          --== PACKAGES ==--
         
[ INFO  ] Checking for product updates...
[ ERROR ] Yum: Cannot queue package ovirt-engine-dwh: No package(s) available to install
[ INFO  ] Yum: Performing yum transaction rollback
[ ERROR ] Failed to execute stage 'Environment customization': No package(s) available to install
[ INFO  ] Stage: Clean up
          Log file is located at /var/log/ovirt-engine/setup/ovirt-engine-setup-20140216144156.log
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Execution of setup failed

Version-Release number of selected component (if applicable):
av1

How reproducible:
always

Steps to Reproduce:
1. Install rhevm-dwh and run engine-setup
2.
3.

Actual results:
fails

Expected results:


Additional info:

Comment 1 Alon Bar-Lev 2014-02-17 09:17:25 UTC
yaniv, please patch this for now, I will move names into environment to ease customization.

just patch within spec and build to provide something usable, so actual tests can happen.

Comment 2 Yaniv Lavi 2014-02-19 11:34:56 UTC
Wordaround is to use flag '--offline' with the engine-setup.
Please include the packages and add release note on this.
Will be fixed for next release.


Yaniv

Comment 3 Alon Bar-Lev 2014-02-20 14:20:02 UTC
solution should be similar to what I done to reports[1]

[1] http://gerrit.ovirt.org/#/c/24599/

Comment 4 Yaniv Lavi 2014-02-27 17:24:01 UTC
Did a patch on the dist git for now, need to add a similar patch to what alon added, so we can resolve this via spec file and config customization.



Yaniv

Comment 6 Barak Dagan 2014-03-05 13:58:47 UTC
Verified on av2

rhevm-dwh-3.4.0-0.4.master.20140224152332.el6ev.noarch
rhevm-dwh-setup-3.4.0-0.4.master.20140224152332.el6ev.noarch

rhevm-reports-3.4.0-0.4.master.20140226133324.el6ev.noarch
rhevm-reports-setup-3.4.0-0.4.master.20140226133324.el6ev.noarch


jasperreports-server-pro-5.5.0-7.el6ev.noarch


# rhevm-setup 
[ INFO  ] Stage: Initializing
[ INFO  ] Stage: Environment setup
          Configuration files: ['/etc/ovirt-engine-setup.conf.d/10-packaging-reports.conf', '/etc/ovirt-engine-setup.conf.d/10-packaging.conf', '/etc/ovirt-engine-setup.conf.d/20-setup-ovirt-post.conf']
          Log file: /var/log/ovirt-engine/setup/ovirt-engine-setup-20140305144834.log
          Version: otopi-1.2.0_master (otopi-1.2.0-0.0.master.el6_5)
[ INFO  ] Stage: Environment packages setup
[ INFO  ] Stage: Programs detection
[ INFO  ] Stage: Environment setup
[ INFO  ] Stage: Environment customization
         
          --== PRODUCT OPTIONS ==--
         
          Install Data Warehouse on this host (Yes, No) [Yes]: yes
          Install Reports on this host (Yes, No) [Yes]: yes
         
          --== PACKAGES ==--
         
[ INFO  ] Checking for product updates...
          Setup has found updates for some packages, do you wish to update them now? (Yes, No) [Yes]: 
[ INFO  ] Checking for an update for Setup...
         
          --== NETWORK CONFIGURATION ==--

Comment 7 Jiri Belka 2014-03-06 14:56:10 UTC
Fails on pristine av2 rpms.

Comment 10 Yaniv Lavi 2014-03-12 14:46:14 UTC
*** Bug 1075665 has been marked as a duplicate of this bug. ***

Comment 11 Jiri Belka 2014-03-13 10:40:19 UTC
engine-setup still fails (rhevm-dwh-setup-3.4.0-3.el6ev.noarch)

...
'2014-03-13 11:19:31 ERROR otopi.context context._executeMethod:161 Failed to execute stage 'Misc configuration': [Errno 2] No such file or directory'

relevant part:

2014-03-13 11:19:31 DEBUG otopi.plugins.ovirt_engine_setup.ovirt_engine_dwh.db.schema plugin.executeRaw:366 execute: ['/usr/share/ovirt-engine-dw
h/dbscripts/schema.sh', '-s', 'localhost', '-p', '5432', '-u', 'ovirt_engine_history', '-d', 'ovirt_engine_history', '-l', '/var/log/ovirt-engine
/setup/ovirt-engine-setup-20140313111652.log', '-c', 'apply'], executable='None', cwd='None', env={'LESSOPEN': '|/usr/bin/lesspipe.sh %s', 'SSH_C
LIENT': '10.34.131.48 34141 22', 'SELINUX_USE_CURRENT_RANGE': '', 'LOGNAME': 'root', 'USER': 'root', 'QTDIR': '/usr/lib64/qt-3.3', 'PATH': '/usr/
lib64/qt-3.3/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin', 'LANG': 'en_US.utf8', 'QTLIB': '/usr/lib64/qt-3.3/lib',
 'TERM': 'screen', 'SHELL': '/bin/bash', 'QTINC': '/usr/lib64/qt-3.3/include', 'G_BROKEN_FILENAMES': '1', 'HISTSIZE': '1000', 'XMODIFIERS': '@im=
none', 'HOME': '/root', 'PYTHONPATH': '/usr/share/ovirt-engine/setup/bin/..::', 'SSH_AUTH_SOCK': '/tmp/ssh-apWyJe7491/agent.7491', 'SELINUX_ROLE_
REQUESTED': '', 'MAIL': '/var/spool/mail/root', 'DBFUNC_DB_PGPASSFILE': '/tmp/tmpAraXVQ', 'LS_COLORS': 'rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=
01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tg
z=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31
:*.xz=01;31:*.bz2=01;31:*.tbz=01;31:*.tbz2=01;31:*.bz=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.
cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.x
pm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*
.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.
flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx
=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=01;36:*.au=01;36:*.flac=01;36:*.mid=01;36:*.midi=01;36:*.mka=01;36:*.mp3=01;36:*.mpc=01;36:*.ogg=01;36:*.ra=
01;36:*.wav=01;36:*.axa=01;36:*.oga=01;36:*.spx=01;36:*.xspf=01;36:', 'SSH_TTY': '/dev/pts/0', 'HOSTNAME': 'jb-rhevm34.rhev.lab.eng.brq.redhat.co
m', 'SELINUX_LEVEL_REQUESTED': '', 'HISTCONTROL': 'ignoredups', 'SHLVL': '1', 'PWD': '/root', 'CVS_RSH': 'ssh', 'OTOPI_LOGFILE': '/var/log/ovirt-
engine/setup/ovirt-engine-setup-20140313111652.log', 'SSH_CONNECTION': '10.34.131.48 34141 10.34.60.228 22', 'OTOPI_EXECDIR': '/root'}
2014-03-13 11:19:31 DEBUG otopi.plugins.ovirt_engine_setup.ovirt_engine_dwh.db.schema plugin.executeRaw:389 execute-result: ['/usr/share/ovirt-en
gine-dwh/dbscripts/schema.sh', '-s', 'localhost', '-p', '5432', '-u', 'ovirt_engine_history', '-d', 'ovirt_engine_history', '-l', '/var/log/ovirt
-engine/setup/ovirt-engine-setup-20140313111652.log', '-c', 'apply'], exception
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/otopi/plugin.py", line 376, in executeRaw
    env=env,
  File "/usr/lib64/python2.6/subprocess.py", line 642, in __init__
    errread, errwrite)
  File "/usr/lib64/python2.6/subprocess.py", line 1234, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory
2014-03-13 11:19:31 DEBUG otopi.context context._executeMethod:152 method exception
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/otopi/context.py", line 142, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-engine/setup/bin/../plugins/ovirt-engine-setup/ovirt-engine-dwh/db/schema.py", line 244, in _misc
    odwhcons.DBEnv.PGPASS_FILE
  File "/usr/lib/python2.6/site-packages/otopi/plugin.py", line 432, in execute
    **kwargs
  File "/usr/lib/python2.6/site-packages/otopi/plugin.py", line 376, in executeRaw
    env=env,
  File "/usr/lib64/python2.6/subprocess.py", line 642, in __init__
    errread, errwrite)
  File "/usr/lib64/python2.6/subprocess.py", line 1234, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory

so I tried to change 'schema.sh' to 'create_schema.sh'...

engine-setup fails as well:

...
'RuntimeError: Command '/usr/share/ovirt-engine-dwh/dbscripts/create_schema.sh' failed to execute
2014-03-13 11:29:29 ERROR otopi.context context._executeMethod:161 Failed to execute stage 'Misc configuration': Command '/usr/share/ovirt-engine-dwh/dbscripts/create_schema.sh' failed to execute'

relevant part:

2014-03-13 11:29:29 DEBUG otopi.plugins.ovirt_engine_setup.ovirt_engine_dwh.db.schema plugin.executeRaw:366 execute: ['/usr/share/ovirt-engine-dw
h/dbscripts/create_schema.sh', '-s', 'localhost', '-p', '5432', '-u', 'ovirt_engine_history', '-d', 'ovirt_engine_history', '-l', '/var/log/ovirt
-engine/setup/ovirt-engine-setup-20140313112758.log', '-c', 'apply'], executable='None', cwd='None', env={'LESSOPEN': '|/usr/bin/lesspipe.sh %s',
 'SSH_CLIENT': '10.34.131.48 34141 22', 'SELINUX_USE_CURRENT_RANGE': '', 'LOGNAME': 'root', 'USER': 'root', 'QTDIR': '/usr/lib64/qt-3.3', 'PATH':
 '/usr/lib64/qt-3.3/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin', 'LANG': 'en_US.utf8', 'QTLIB': '/usr/lib64/qt-3.
3/lib', 'TERM': 'screen', 'SHELL': '/bin/bash', 'QTINC': '/usr/lib64/qt-3.3/include', 'G_BROKEN_FILENAMES': '1', 'HISTSIZE': '1000', 'XMODIFIERS'
: '@im=none', 'HOME': '/root', 'PYTHONPATH': '/usr/share/ovirt-engine/setup/bin/..::', 'SSH_AUTH_SOCK': '/tmp/ssh-apWyJe7491/agent.7491', 'SELINU
X_ROLE_REQUESTED': '', 'MAIL': '/var/spool/mail/root', 'DBFUNC_DB_PGPASSFILE': '/tmp/tmpu7Qelx', 'LS_COLORS': 'rs=0:di=01;34:ln=01;36:mh=00:pi=40
;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;
31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.l
z=01;31:*.xz=01;31:*.bz2=01;31:*.tbz=01;31:*.tbz2=01;31:*.bz=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=0
1;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01
;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=
01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=0
1;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;3
5:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=01;36:*.au=01;36:*.flac=01;36:*.mid=01;36:*.midi=01;36:*.mka=01;36:*.mp3=01;36:*.mpc=01;36:*.ogg=01;3
6:*.ra=01;36:*.wav=01;36:*.axa=01;36:*.oga=01;36:*.spx=01;36:*.xspf=01;36:', 'SSH_TTY': '/dev/pts/0', 'HOSTNAME': 'jb-rhevm34.rhev.lab.eng.brq.re
dhat.com', 'SELINUX_LEVEL_REQUESTED': '', 'HISTCONTROL': 'ignoredups', 'SHLVL': '1', 'PWD': '/root', 'CVS_RSH': 'ssh', 'OTOPI_LOGFILE': '/var/log
/ovirt-engine/setup/ovirt-engine-setup-20140313112758.log', 'SSH_CONNECTION': '10.34.131.48 34141 10.34.60.228 22', 'OTOPI_EXECDIR': '/root'}
2014-03-13 11:29:29 DEBUG otopi.plugins.ovirt_engine_setup.ovirt_engine_dwh.db.schema plugin.executeRaw:383 execute-result: ['/usr/share/ovirt-en
gine-dwh/dbscripts/create_schema.sh', '-s', 'localhost', '-p', '5432', '-u', 'ovirt_engine_history', '-d', 'ovirt_engine_history', '-l', '/var/lo
g/ovirt-engine/setup/ovirt-engine-setup-20140313112758.log', '-c', 'apply'], rc=1
2014-03-13 11:29:29 DEBUG otopi.plugins.ovirt_engine_setup.ovirt_engine_dwh.db.schema plugin.execute:441 execute-output: ['/usr/share/ovirt-engin
e-dwh/dbscripts/create_schema.sh', '-s', 'localhost', '-p', '5432', '-u', 'ovirt_engine_history', '-d', 'ovirt_engine_history', '-l', '/var/log/o
virt-engine/setup/ovirt-engine-setup-20140313112758.log', '-c', 'apply'] stdout:
Usage: create_schema.sh [-h] [-s SERVERNAME [-p PORT]] [-d DATABASE] [-u USERNAME] [-l LOGFILE] [-g] [-m MD5DIR] [-v]

        -s SERVERNAME - The database servername for the database  (def. localhost)
        -p PORT       - The database port for the database        (def. 5432)
        -d DATABASE   - The database name                         (def. ovirt_engine_history)
        -u USERNAME   - The username for the database             (def. engine)
        -l LOGFILE    - The logfile for capturing output          (def. /var/log/ovirt-engine/setup/ovirt-engine-setup-20140313112758.log)
        -g NOMD5      - Do not generate MD55 for files (generated in dev env only) (def. false
        -m MD5DIR     - The directory for generated MD5 files (generated in dev env only) (def. /usr/share/ovirt-engine-dwh/dbscripts
        -v            - Turn on verbosity                         (WARNING: lots of output)
        -h            - This help text.


2014-03-13 11:29:29 DEBUG otopi.plugins.ovirt_engine_setup.ovirt_engine_dwh.db.schema plugin.execute:446 execute-output: ['/usr/share/ovirt-engine-dwh/dbscripts/create_schema.sh', '-s', 'localhost', '-p', '5432', '-u', 'ovirt_engine_history', '-d', 'ovirt_engine_history', '-l', '/var/log/ovirt-engine/setup/ovirt-engine-setup-20140313112758.log', '-c', 'apply'] stderr:


2014-03-13 11:29:29 DEBUG otopi.context context._executeMethod:152 method exception
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/otopi/context.py", line 142, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-engine/setup/bin/../plugins/ovirt-engine-setup/ovirt-engine-dwh/db/schema.py", line 244, in _misc
    odwhcons.DBEnv.PGPASS_FILE
  File "/usr/lib/python2.6/site-packages/otopi/plugin.py", line 451, in execute
    command=args[0],
RuntimeError: Command '/usr/share/ovirt-engine-dwh/dbscripts/create_schema.sh' failed to execute

something with arguments..., maybe '-c apply'?

Comment 12 Jiri Belka 2014-03-13 10:41:52 UTC
Created attachment 873908 [details]
ovirt-engine-setup-$date.log(s)

- older with default 'schema.sh' issue
- 2nd with changed filename ('schema.sh' -> 'create_schema.sh')...

(not sure if this was relevant but 'schema.sh' does not exist at all in /usr/share/ovirt-engine-*)

Comment 13 Yaniv Lavi 2014-03-13 10:46:07 UTC
Why is the package not updating correctly?



Yaniv

Comment 14 Yaniv Lavi 2014-03-13 11:12:24 UTC
Please try to manually update dwh package and try again. I think this should solve this and this isn't a real issue because it will only happen between the av1\2 to the rest.


Yaniv

Comment 15 Alon Bar-Lev 2014-03-13 12:28:50 UTC
2014-03-13 11:28:18 DEBUG otopi.plugins.ovirt_engine_setup.ovirt_engine_common.distro-rpm.packages packages.verbose:178 Yum: queue package rhevm-dwh for update
2014-03-13 11:28:18 DEBUG otopi.plugins.ovirt_engine_setup.ovirt_engine_common.distro-rpm.packages packages.verbose:178 Yum: package rhevm-dwh queued

2014-03-13 11:28:18 DEBUG otopi.plugins.ovirt_engine_setup.ovirt_engine_common.distro-rpm.packages packages.verbose:178 Yum: Building transaction
2014-03-13 11:28:18 DEBUG otopi.plugins.ovirt_engine_setup.ovirt_engine_common.distro-rpm.packages packages.verbose:178 Yum: Empty transaction


there was no update for rhevm-dwh... this is strange.
can you please checkout yum update rhevm-dwh if show anything?

Comment 16 Jiri Belka 2014-03-13 12:37:38 UTC
As 'Fixed in version' states only rhevm-dwh-setup, I just manually updated only this package (as av3 is not officially out, hehe). I will give it then another try...

Comment 17 Kiril Nesenko 2014-03-13 12:39:15 UTC
(In reply to Jiri Belka from comment #16)
> As 'Fixed in version' states only rhevm-dwh-setup, I just manually updated
> only this package (as av3 is not officially out, hehe). I will give it then
> another try...

Better is to test it with official av3. Because we might rebuild engine as well.

- Kiril

Comment 18 Yaniv Lavi 2014-03-16 12:19:15 UTC
Moving to ON_QA since nothing devel needs to do here. Please test when release is out the door according to fix version.



Yaniv

Comment 19 Jiri Belka 2014-03-17 12:54:03 UTC
ok, av3.

Comment 20 errata-xmlrpc 2014-06-09 15:18:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0601.html