Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1065691

Summary: SELinux is preventing /usr/bin/touch from 'write' accesses on the file .
Product: [Fedora] Fedora Reporter: Nicolas Mailhot <nicolas.mailhot>
Component: selinux-policyAssignee: Miroslav Grepl <mgrepl>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: dominick.grift, dwalsh, lvrabec, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:015503aaa0a6ddc9e4260a1f0021ce9087c36ba33541e92a751c53faa89c17ff
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-02-17 08:55:00 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Nicolas Mailhot 2014-02-15 22:18:16 UTC
Description of problem:
SELinux is preventing /usr/bin/touch from 'write' accesses on the file .

*****  Plugin catchall (100. confidence) suggests   **************************

If vous pensez que touch devrait être autorisé à accéder write sur  file par défaut.
Then vous devriez rapporter ceci en tant qu'anomalie.
Vous pouvez générer un module de stratégie local pour autoriser cet accès.
Do
autoriser cet accès pour le moment en exécutant :
# grep touch /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:init_t:s0
Target Context                system_u:object_r:ddclient_var_t:s0
Target Objects                 [ file ]
Source                        touch
Source Path                   /usr/bin/touch
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           coreutils-8.22-10.fc21.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-24.fc21.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.14.0-0.rc2.git4.1.fc21.x86_64 #1
                              SMP Fri Feb 14 20:03:13 UTC 2014 x86_64 x86_64
Alert Count                   1
First Seen                    2014-02-15 23:13:43 CET
Last Seen                     2014-02-15 23:13:43 CET
Local ID                      fbb5897b-cfbe-4fd2-bb4d-0e5b5ddcbf30

Raw Audit Messages
type=AVC msg=audit(1392502423.355:63): avc:  denied  { write } for  pid=1102 comm="touch" name="ddclient.cache" dev="dm-0" ino=2883636 scontext=system_u:system_r:init_t:s0 tcontext=system_u:object_r:ddclient_var_t:s0 tclass=file


type=SYSCALL msg=audit(1392502423.355:63): arch=x86_64 syscall=utimensat success=no exit=EACCES a0=ffffffffffffff9c a1=7fff6a124f19 a2=0 a3=0 items=0 ppid=1 pid=1102 auid=4294967295 uid=987 gid=982 euid=987 suid=987 fsuid=987 egid=982 sgid=982 fsgid=982 tty=(none) ses=4294967295 comm=touch exe=/usr/bin/touch subj=system_u:system_r:init_t:s0 key=(null)

Hash: touch,init_t,ddclient_var_t,file,write

Additional info:
reporter:       libreport-2.1.12
hashmarkername: setroubleshoot
kernel:         3.14.0-0.rc2.git4.1.fc21.x86_64
type:           libreport

Comment 1 Miroslav Grepl 2014-02-17 08:55:00 UTC

*** This bug has been marked as a duplicate of bug 1065693 ***