Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1065466

Summary: [Cartridge] [JBoss] Cartridge manifest.yml missing
Product: OpenShift Container Platform Reporter: Frederic Hornain <fhornain>
Component: ImageAssignee: Jason DeTiberus <jdetiber>
Status: CLOSED CURRENTRELEASE QA Contact: libra bugs <libra-bugs>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 2.0.0CC: bleanhar, fhornain, libra-onpremise-devel
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-02-14 18:39:34 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Frederic Hornain 2014-02-14 17:41:47 UTC
Description of problem:

[root@node1 jbosseap-6.0]# oo-admin-cartridge -a install -s /usr/libexec/openshift/cartridges/jbosseap-6.0

install failed for /usr/libexec/openshift/cartridges/jbosseap-6.0: Cartridge manifest.yml missing: '/usr/libexec/openshift/cartridges/jbosseap-6.0/metadata/manifest.yml'
installation failed

[root@node1 jbosseap-6.0]# locate manifest.yml
/usr/libexec/openshift/cartridges/jbosseap-6.0/info/manifest.yml



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Brenton Leanhardt 2014-02-14 17:46:43 UTC
Are you sure you are using OpenShift Enterprise 2.x?  /usr/libexec/openshift/cartridges/jbosseap-6.0 only existed early in the 1.x lifecycle.

Now the correct cartridge directory is /usr/libexec/openshift/cartridges/jbosseap.  What does rpm -qf /usr/libexec/openshift/cartridges/jbosseap-6.0 report?

The latest version is 2.11.1.2-1.el6op.

Comment 3 Frederic Hornain 2014-02-14 17:54:36 UTC
Oops, I did not have time to explain what went wrong.

I use the official packages from red hat to install the JBoss cartridges.
Then I ran the oo-admin-cartridge command - see above -.

And I had the following error message -  see above -

Comment 4 Frederic Hornain 2014-02-14 17:55:28 UTC
Meanwhile, I tied with EWS and it worked.

oo-admin-cartridge -a install -s /usr/libexec/openshift/cartridges/jbossews
succeeded

Comment 5 Frederic Hornain 2014-02-14 17:57:57 UTC
Hi Brenton,

> Are you sure you are using OpenShift Enterprise 2.x?
Yes.

> What does rpm -qf /usr/libexec/openshift/cartridges/jbosseap-6.0 report?
openshift-origin-cartridge-jbosseap-6.0-1.0.5-1.el6op.noarch

Should I remove that cartridge ? And With what should I replace it ?

Comment 6 Brenton Leanhardt 2014-02-14 17:59:26 UTC
Would you mind sharing the installation instructions you followed?  If your intention is a new OSE 2.0 installation then you have most likely followed the 1.x instructions since that package is from the 1.x timeframe.

Comment 7 Frederic Hornain 2014-02-14 18:09:49 UTC
Brenton,

I think I know where it come from.
At the beginning, I tried to install JBoss EAP cartridge in using the :
- Red Hat OpenShift Enterprise 2.0 Client Tools - x86_64
- Red Hat OpenShift Enterprise 2.0 Node - x86_64
channels.

But at certain point of time, the yum install process indicated me that it needed the following package openshift-origin-cartridge-abstract which was not in the Red Hat OpenShift Enterprise 2.0 Node - x86_64  channel.

Therefore, I red in the documentation that I needed to attached the  Red Hat OpenShift Enterprise Node channel to install it.

Thing that I did.

Therefore, I am going to remove "openshift-origin-cartridge-jbosseap-6.0.noarch 0:1.0.5-1.el6op"   

but what package from "Red Hat OpenShift Enterprise 2.0 Node - x86_64" should I install to have JBoss EAP cartridge ? 
jboss-eap6-index-6.0.1.GA-2.el6op.noarch ?
or jboss-eap6-modules-6.0.0.GA-8.el6op.noarch ?

Comment 8 Frederic Hornain 2014-02-14 18:13:57 UTC
Brenton,

Well, I think the "openshift-origin-cartridge-abstract" dependency was coming from one of the packages in the "Red Hat OpenShift Enterprise JBoss EAP addon - x86_64" channel.

Thanks in advance for your support and your time.

BR
/f

Comment 9 Brenton Leanhardt 2014-02-14 18:22:59 UTC
You should definitely remove openshift-origin-cartridge-jbosseap-6.0.  The actual package you want is called openshift-origin-cartridge-jbosseap (note the missing version number in the name).

If you would like to sanity check your installation, here are the latest openshift packages we have shipped:

jenkins-plugin-openshift-0.6.25-1.el6op
openshift-enterprise-upgrade-2.0.1-1.el6op
openshift-origin-broker-1.15.3-1.el6op
openshift-origin-broker-util-1.17.6.2-1.el6op
openshift-origin-cartridge-cron-1.16.3-1.el6op
openshift-origin-cartridge-diy-1.16.1-2.el6op
openshift-origin-cartridge-haproxy-1.17.3.1-1.el6op
openshift-origin-cartridge-jbosseap-2.11.1.2-1.el6op
openshift-origin-cartridge-jbossews-1.17.2.1-1.el6op
openshift-origin-cartridge-jenkins-1.16.1-2.el6op
openshift-origin-cartridge-jenkins-client-1.17.1-2.el6op
openshift-origin-cartridge-mock-1.16.1-2.el6op
openshift-origin-cartridge-mock-plugin-1.16.1-2.el6op
openshift-origin-cartridge-mysql-1.18.3-1.el6op
openshift-origin-cartridge-nodejs-1.18.1-2.el6op
openshift-origin-cartridge-perl-1.16.6-1.el6op
openshift-origin-cartridge-php-1.17.3.2-1.el6op
openshift-origin-cartridge-postgresql-1.17.3.3-1.el6op
openshift-origin-cartridge-python-1.17.7-1.el6op
openshift-origin-cartridge-ruby-1.17.4-1.el6op
openshift-origin-console-1.15.1.2-2.el6op
openshift-origin-msg-common-1.16.3-1.el6op
openshift-origin-msg-node-mcollective-1.17.5-1.el6op
openshift-origin-node-proxy-1.16.4-2.el6op
openshift-origin-node-util-1.17.4-2.el6op
openshift-origin-util-scl-1.16.1-2.el6op
pam_openshift-1.10.1-2.el6op
rubygem-openshift-origin-admin-console-1.16.3.2-1.el6op
rubygem-openshift-origin-auth-remote-user-1.17.1-2.el6op
rubygem-openshift-origin-common-1.17.2.6-1.el6op
rubygem-openshift-origin-console-1.17.6.5-1.el6op
rubygem-openshift-origin-container-selinux-0.4.1-2.el6op
rubygem-openshift-origin-controller-1.17.12-1.el6op
rubygem-openshift-origin-dns-nsupdate-1.15.1-2.el6op
rubygem-openshift-origin-frontend-apache-mod-rewrite-0.3.1-2.el6op
rubygem-openshift-origin-frontend-apache-vhost-0.2.2-2.el6op
rubygem-openshift-origin-frontend-apachedb-0.2.2-2.el6op
rubygem-openshift-origin-frontend-haproxy-sni-proxy-0.2.1-2.el6op
rubygem-openshift-origin-frontend-nodejs-websocket-0.2.2-2.el6op
rubygem-openshift-origin-msg-broker-mcollective-1.17.4-1.el6op
rubygem-openshift-origin-node-1.17.5.6-1.el6op
rubygem-openshift-origin-routing-activemq-0.2.2-1.el6op

Comment 10 Frederic Hornain 2014-02-14 18:35:03 UTC
Ok, it works now.
Thanks for your help and support.

BR
/f

Comment 11 Brenton Leanhardt 2014-02-14 18:39:34 UTC
No problem!  If you can think of anything that could be more clear in the installation process feel free to file another bug.  On a new 2.0 installation I don't think openshift-origin-cartridge-abstract should be referenced in any way.  It's unfortunately easy to attach the wrong RHN channels which can certainly lead to confusion.  The oo-admin-yum-validator tool can be used to sanity check and fix common problems.

https://access.redhat.com/site/documentation/en-US/OpenShift_Enterprise/2/html-single/Deployment_Guide/#Configuring_Yum_on_Broker_Hosts

https://access.redhat.com/site/documentation/en-US/OpenShift_Enterprise/2/html-single/Deployment_Guide/#Configuring_Yum_on_Node_Hosts