Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1064816

Summary: [RFE] Improve robustness of storage allocation
Product: [Fedora] Fedora Reporter: Marian Csontos <mcsontos>
Component: python-blivetAssignee: David Lehman <dlehman>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: agk, amulhern, anaconda-maint-list, bcl, dlehman, g.kaviyarasu, jonathan, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: python-blivet-0.44-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-03-31 21:25:50 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Marian Csontos 2014-02-13 11:05:24 UTC
Anaconda tries to create whole storage layout and then commit it in one transaction. This is not an easy problem and sometimes goes wrong because the free space is short of just a few megabytes.

As discussed in Brno the LVM team is trying to make some changes to address the issue but there will be still cases (e.g. mdraid and crypt-setup devices) which won't be handled.

Recalculating volume sizes according to remaining free space after every step would fix these failures and make anaconda more robust.

There are further constraints which anaconda is aware of and is the one who should ensure they are met:

1. system disk MUST be able to hold installed packages
2. smaller volumes SHOULD be allocated first as being few 100 megabytes short on large volumes is less an issue than on very small partitions like /boot

Comment 1 Brian Lane 2014-02-14 16:29:16 UTC
Note that is would be *very* useful if the storage systems like lvm and mdadm were able to accurately report what they are going to use instead of us having to guess and fudge.

Comment 2 David Lehman 2014-03-31 21:25:50 UTC
Blivet should now correct LV sizes as needed before creating them based on VG free space.