Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1063996

Summary: Move sparse raw disk from NFS to iSCSI domain is not supported
Product: [Retired] oVirt Reporter: Dafna Ron <dron>
Component: ovirt-engine-webadminAssignee: Tal Nisan <tnisan>
Status: CLOSED CURRENTRELEASE QA Contact: Aharon Canan <acanan>
Severity: high Docs Contact:
Priority: urgent    
Version: unspecifiedCC: acanan, acathrow, amureini, dron, ecohen, gklein, iheim, mgoldboi, scohen, yeylon
Target Milestone: ---   
Target Release: 3.4.1   
Hardware: x86_64   
OS: Linux   
Whiteboard: storage
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-05-08 13:36:03 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Storage RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1052318, 1084789    
Attachments:
Description Flags
logs and screenshots none

Description Dafna Ron 2014-02-11 18:14:24 UTC
Created attachment 861928 [details]
logs and screenshots

Description of problem:

since raw+spars is not supported to be migrated to an iscsi domain I think that perhaps we should rethink having thin provision set as default for nfs.
the problem with having a thin provision disk as default for nfs is that we cannot move the disk to an iscsi type domain while we can for preallocated disk. 

not sure if this is a bug or if this can be solved some how, but I think a discussion needs to happen on this due to the changes in DC which allows mixed type domains to be created under the same pool. 

Version-Release number of selected component (if applicable):

ovirt-engine-webadmin-portal-3.4.0-0.7.beta2.el6.noarch

How reproducible:

100%

Steps to Reproduce:
1. create a pool with 1 iscsi and 1 nfs domains
2. create a vm with a disk on the nfs domain (default choice is thin provision)
3. try to move the disk to the iscsi domain 

Actual results:

spars+raw is not supported for move to iscsi type domain and yet it's a default choice for nfs. 

Expected results:

not sure its a bug but this should be discussed and at least have a big red release note... 

Additional info:

2014-02-11 12:58:14,703 WARN  [org.ovirt.engine.core.bll.MoveOrCopyDiskCommand] (ajp--127.0.0.1-8702-7) [c4d3607] CanDoAction of action MoveOrCopyDisk failed. Reasons:VAR__ACTION__MOVE,VAR__TYPE__VM_DISK,ACTION_TYPE_FAILED_DISK_CONFIGURA
TION_NOT_SUPPORTED,$volumeFormat RAW,$volumeType Sparse

Comment 1 Itamar Heim 2014-02-16 08:23:36 UTC
Setting target release to current version for consideration and review. please
do not push non-RFE bugs to an undefined target release to make sure bugs are
reviewed for relevancy, fix, closure, etc.

Comment 2 Allon Mureinik 2014-04-06 14:11:29 UTC
Patch need's to be backported, returning to POST

Comment 3 Allon Mureinik 2014-04-30 13:53:13 UTC
(In reply to Dafna Ron from comment #0)
> Actual results:
> 
> spars+raw is not supported for move to iscsi type domain and yet it's a
> default choice for nfs. 
> 
> Expected results:
> 
> not sure its a bug but this should be discussed and at least have a big red
> release note... 
Moving this disk became possible with the fix of bug 1064068, so I guess /this/ bug no longer has a point?

Comment 5 Aharon Canan 2014-04-30 14:20:07 UTC
not relevant, 
we will test and track the RFE (1064068)

Comment 6 Sandro Bonazzola 2014-05-08 13:36:03 UTC
This is an automated message

oVirt 3.4.1 has been released:
 * should fix your issue
 * should be available at your local mirror within two days.

If problems still persist, please make note of it in this bug report.