Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1063906

Summary: netstat abort with -A inet
Product: Red Hat Enterprise Linux 7 Reporter: Hubert Kario <hkario>
Component: net-toolsAssignee: Jiri Popelka <jpopelka>
Status: CLOSED CURRENTRELEASE QA Contact: Leos Pol <lpol>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.0CC: jkoncick, jpopelka, jscotka, ovasik
Target Milestone: rcKeywords: Patch, Regression
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: net-tools-2.0-0.16.20131004git.el7 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-06-13 11:46:51 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1039625    
Attachments:
Description Flags
Patch none

Description Hubert Kario 2014-02-11 15:45:03 UTC
Description of problem:
When running `netstat -n -A inet`, the application aborts execution with error message

Version-Release number of selected component (if applicable):
net-tools-2.0-0.15.20131004git.el7.x86_64

How reproducible:
Alwyas

Steps to Reproduce:
1. netstat -n -A inet

Actual results:
Active Internet connections (w/o servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State      
tcp        0      0 192.168.122.125:22      192.168.122.1:51954     ESTABLISHED
netstat: no support for `AF INET (sctp)' on this system.

Expected results:
echo $?
0

Additional info:
running `modprobe sctp` makes the error go away.

Comment 1 Jiri Popelka 2014-02-11 16:19:50 UTC
Thanks.
This was once reported and fixed as bug #229232, so it's a regression (I must have dropped the patch during 1.60 -> pre2.0 move).

Comment 3 Jaromír Končický 2014-02-11 18:00:36 UTC
Created attachment 861915 [details]
Patch

Here is the patch, took from 1.60 version and adjusted to fit RHEL7 2.0 version. It suppresses the error message.
I noticed this message shows up in Fedora version too.

Comment 4 Jaromír Končický 2014-02-11 18:23:02 UTC
Thinking about it, it seems that adding "If the sctp module is not added to the kernel..." into manpage is actually pointless, because with the patch it no longer prints that message. So adding comment into man page and fixing the source are both excluding each other.

Comment 7 Jaromír Končický 2014-02-14 09:46:50 UTC
Here I made a different (and probably better) solution of this problem:
https://bugzilla.redhat.com/show_bug.cgi?id=1063913#c7

Comment 10 Ludek Smid 2014-06-13 11:46:51 UTC
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.