Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1063833

Summary: HAProxy put gear with Wordpress down when it returns 500
Product: OpenShift Online Reporter: Michal Fojtik <mfojtik>
Component: ImageAssignee: Michal Fojtik <mfojtik>
Status: CLOSED CURRENTRELEASE QA Contact: libra bugs <libra-bugs>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 2.xCC: wjiang
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-02-26 19:12:24 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
wordpress quickstart scale-up failed log none

Description Michal Fojtik 2014-02-11 13:47:22 UTC
Description of problem:

When installing WordPress cartridge, after installation Wordpress return 500 with HTML body informing user that the configuration file needs to be created.

However, when I use '-s', haproxy shows the gear as down and does not route traffic to it...

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. rhc app create wordpress -s php-5.4 mysql-5.5 --from-code=https://github.com/openshift/wordpress-example
2. curl http://wordpress-mfojtik.dev.rhcloud.com # => return 503
3. rhc ssh -a wordpress
4. curl http://$OPENSHIFT_PHP_IP:$OPENSHIFT_PHP_PORT/ # => return 500, however valid HTML body

Actual results:

Wordpress installation cannot be finished, because the app is not accesible via haproxy.

Expected results:

HAproxy should forward traffic to application when the error code is 500 (Internal Server Error).

Additional info:

(i'm not 100% i'm convinced this is a bug in haproxy or in wordpress cartridge (definitely a bug in wordpress ;-))

Comment 1 Michal Fojtik 2014-02-11 14:14:08 UTC
Should be fixed here:

https://github.com/openshift/wordpress-example/pull/45

Comment 2 weiwei jiang 2014-02-12 05:04:58 UTC
Created attachment 862117 [details]
wordpress quickstart scale-up failed log

Tried with the latest code, but when I scale up a wordpress quickstart application, it failed, detail info refer to attachment.

Comment 3 Michal Fojtik 2014-02-12 14:00:58 UTC
Should be now fixed here:

https://github.com/openshift/wordpress-example/pull/46

I tried to:

1. create wp app w/o scaled
2. create wp app with scaped
3. rhc app-scale-up -a wp
4. add custom theme/plugin to scaled and git push

all from the above worked perfectly on devenv.

Comment 4 weiwei jiang 2014-02-13 02:50:18 UTC
Tried with the latest code and wordpress quickstart application can be scale-uped well now.