Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1063611

Summary: Got 502 "Proxy error" when access the new app on INT
Product: OpenShift Online Reporter: weiwei jiang <wjiang>
Component: ContainersAssignee: Rajat Chopra <rchopra>
Status: CLOSED CURRENTRELEASE QA Contact: libra bugs <libra-bugs>
Severity: high Docs Contact:
Priority: high    
Version: 2.xCC: admiller, dmcphers, jhonce, jhou, rchopra, wsun, xtian
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-02-18 16:50:02 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description weiwei jiang 2014-02-11 06:47:06 UTC
Description of problem:
After create app successfully, try to access the app in browser, got 502

Version-Release number of selected component (if applicable):
INT(devenv_4356)

How reproducible:
always

Steps to Reproduce:
1.Create a app 
2.Access the app in browser
3.

Actual results:
Got 502

Expected results:
Should work well

Additional info:

Comment 1 Jhon Honce 2014-02-11 19:41:24 UTC
Please re-test some INT nodes were not configured correctly.

Comment 2 weiwei jiang 2014-02-12 02:20:29 UTC
I found this should duplicate with https://bugzilla.redhat.com/show_bug.cgi?id=1064082 , and this is not a bug?

Comment 3 weiwei jiang 2014-02-12 05:39:56 UTC
I saw the email said this will be fixed tomorrow, so I will verified this when it has been fixed tomorrow.

Comment 4 weiwei jiang 2014-02-13 06:44:20 UTC
checked ok INT(devenv_4369) and found not all app can be accessed.
for example:
php53s-migration.int.rhcloud.com work well
php54s-migration.int.rhcloud.com got 502

Comment 5 Rajat Chopra 2014-02-13 18:50:42 UTC
php54s-migration.int.rhcloud.com, this app seems to have been deleted.
Please provide another example app that does not work. For debugging.

Comment 7 Rajat Chopra 2014-02-14 03:36:30 UTC
If you restart the apps, do you still get 502?

Comment 10 Adam Miller 2014-02-14 19:38:09 UTC
This was a configuration issue, somehow ex-std-node1.int.rhcloud.com became out of sync on the routing configuration for the node level apache.

All apps listed as returning 502 errors are no longer doing so.

Apologies.

Comment 11 weiwei jiang 2014-10-11 08:27:48 UTC
Checked on INT(devenv_5223), and can not reproduce this issue, so verify this.