Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1063213

Summary: pulp-admin fails to recognize rpm repo publish error
Product: [Retired] Pulp Reporter: mkovacik
Component: rpm-supportAssignee: Randy Barlow <rbarlow>
Status: CLOSED CURRENTRELEASE QA Contact: pulp-qe-list
Severity: unspecified Docs Contact:
Priority: high    
Version: MasterCC: mhrivnak, skarmark
Target Milestone: ---Keywords: Triaged
Target Release: 2.4.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-08-09 06:56:44 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Screen log
none
verifying screen log none

Description mkovacik 2014-02-10 09:55:13 UTC
Created attachment 861309 [details]
Screen log

Description of problem:
when called, pulp-admin rpm repo publish run --repo-id <a repo id> fails to propagate/report publish failures although one can see a publish error entry in log file ~/.pulp/server_calls.log

Version-Release number of selected component (if applicable):
pulp-admin-client-2.4.0-0.2.alpha.git.1.e941874.fc20.noarch

How reproducible:
Always

Steps to Reproduce:
1. create rpm repo
2. sync rpm repo
3. publish rpm repo (make sure rpm publishing fails)

Actual results:
pulp-admin fails to recognize the publish failure

Expected results:
pulp-admin propagates/reports publishing failure

Additional info:
See also Bug #1063207

Comment 1 Jeff Ortel 2014-04-03 13:36:09 UTC
build: 2.4.0-0.7.beta

Comment 2 mkovacik 2014-04-25 14:16:40 UTC
Created attachment 889774 [details]
verifying screen log

Verified by introducing a custom RuntimeError for publiher in version: pulp-admin-client-2.4.0-0.10.beta.git.1.7406489.fc20.noarch
For more details, check the verifying screen log

Comment 3 mkovacik 2014-04-25 14:17:18 UTC
State change based on Comment#2

Comment 4 Randy Barlow 2014-08-09 06:56:44 UTC
This has been fixed in Pulp 2.4.0-1.