Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1063175

Summary: Multiple emails received when cancelling needinfo on BZ
Product: [Community] Bugzilla Reporter: Pavel Moravec <pmoravec>
Component: Email NotificationsAssignee: PnT DevOps Devs <hss-ied-bugs>
Status: CLOSED DUPLICATE QA Contact: tools-bugs <tools-bugs>
Severity: low Docs Contact:
Priority: medium    
Version: 4.4CC: jmcdonal, rjoost
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: All   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-03-11 12:22:32 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1063548    
Bug Blocks:    

Description Pavel Moravec 2014-02-10 08:44:47 UTC
Description of problem:
I suspect sending email notification when cancelling neediinfo flag lacks some sort of unifying the list of email addresses to be notified, leading in cases when the same mail is sent multiple times. I observed it in one particular scenario but think it is more general issue.


Version-Release number of selected component (if applicable):
4.4 (seen in production in Feb 2014)


How reproducible:
100%


Steps to Reproduce:
1. Being in Cc list of a BZ
2. Assigned myself to the BZ
3. Somebody else raising needinfo on me
4. Doing a comment, I clear the needinfo


Actual results:
I got 3 identical mails.


Expected results:
Just one mail to be received


Additional info:
See mail details in next internal comment (not sure if worth to publishing it)

Comment 4 Simon Green 2014-03-11 12:22:32 UTC

*** This bug has been marked as a duplicate of bug 1063548 ***