Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1063086

Summary: "WSDL file from Java" does not work when project is not built
Product: [JBoss] JBoss Fuse Service Works 6 Reporter: Martin Basovník <mbasovni>
Component: ToolingAssignee: Brian Fitzpatrick <bfitzpat>
Status: MODIFIED --- QA Contact: Len DiMaggio <ldimaggi>
Severity: unspecified Docs Contact:
Priority: medium    
Version: unspecifiedCC: kconner, rcernich, soa-p-jira, tsykora
Target Milestone: DR4   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Martin Basovník 2014-02-10 00:16:17 UTC
Description of problem:
Creating of WSDL file from Java service interface does not work on Ubuntu, but it seems it works on Fedora and RHEL. You can see exception thrown by JBDS plugin bellow. This exception is thrown both when used OpenJDK and OracleJDK. On Fedora, this feature works! 3 people with Ubuntu confirmed problem on Ubuntu while 3 other people confirmed that it works on fedora. I also copied my JBDS instance from Ubuntu to RHEL6 and it worked there. I think problem may be in the the class "" ( in static method "ClassLoader getProjectBuildClassLoader(IJavaProject javaProject);".

System info:

OS: Linux basovnik 3.11.0-15-generic #25-Ubuntu SMP Thu Jan 30 17:22:01 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
  java version "1.7.0_45"
  Java(TM) SE Runtime Environment (build 1.7.0_45-b18)
  Java HotSpot(TM) 64-Bit Server VM (build 24.45-b08, mixed mode)
JBDS vesion: 7.1.0.GA (Eclipse atribute "-vm" was set to default java)
Switchyard plugin version: 1.1.4.v20140122-1953-H431-Final

Version-Release number of selected component (if applicable):
1.1.4.v20140122-1953-H431-Final (The problem is probably also in older versions.)

How reproducible:

Steps to Reproduce:
1. Open JBDS on Ubuntu
2. Right-click on a service interface. New -> "WSDL file from Java"
3. Next -> Finish (do not change anything)

Actual results:
Mon Feb 10 00:40:53 CET 2014
WSDL generation failed.

java.lang.ClassNotFoundException: org.switchyard.quickstarts.bean.service.InventoryService
	at Method)
	at java.lang.ClassLoader.loadClass(
	at java.lang.ClassLoader.loadClass(
	at org.eclipse.jface.operation.ModalContext.runInCurrentThread(
	at org.eclipse.jface.wizard.WizardDialog.finishPressed(
	at org.eclipse.jface.wizard.WizardDialog.buttonPressed(
	at org.eclipse.jface.dialogs.Dialog$2.widgetSelected(
	at org.eclipse.swt.widgets.TypedListener.handleEvent(
	at org.eclipse.swt.widgets.EventTable.sendEvent(
	at org.eclipse.swt.widgets.Widget.sendEvent(
	at org.eclipse.swt.widgets.Display.runDeferredEvents(
	at org.eclipse.swt.widgets.Display.readAndDispatch(
	at org.eclipse.jface.window.Window.runEventLoop(
	at org.eclipse.jface.action.Action.runWithEvent(
	at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(
	at org.eclipse.jface.action.ActionContributionItem.access$2(
	at org.eclipse.jface.action.ActionContributionItem$5.handleEvent(
	at org.eclipse.swt.widgets.EventTable.sendEvent(
	at org.eclipse.swt.widgets.Widget.sendEvent(
	at org.eclipse.swt.widgets.Display.runDeferredEvents(
	at org.eclipse.swt.widgets.Display.readAndDispatch(
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$
	at org.eclipse.core.databinding.observable.Realm.runWithDefault(
	at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(
	at org.eclipse.ui.internal.Workbench$
	at org.eclipse.core.databinding.observable.Realm.runWithDefault(
	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(
	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(
	at org.eclipse.ui.internal.ide.application.IDEApplication.start(
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(
	at java.lang.reflect.Method.invoke(
	at org.eclipse.equinox.launcher.Main.invokeFramework(
	at org.eclipse.equinox.launcher.Main.basicRun(
	at org.eclipse.equinox.launcher.Main.main(

Expected results:

Additional info:

Comment 1 Rob Cernich 2014-02-18 17:02:42 UTC
Please ensure auto-build is enabled for the project and that the class file exists in the output folder (e.g. target/classes/org/switchyard/quickstarts/bean/service/InventoryService.class)

Comment 2 Martin Basovník 2014-02-19 08:18:47 UTC
I confirm that problems are really caused by missing class in target directory. Problems on ubuntu were just a coincidence. I think that error message should hint the user he has to build the project before using of "Java to WSDL" tool.

Comment 3 Rob Cernich 2014-08-26 21:29:25 UTC
Hey Brian, see if you can't figure out a way to provide a better error message to the user.

Comment 4 Rob Cernich 2014-08-26 21:29:57 UTC
Also, if you could please create and link a JIRA to this.  Thanks.

Comment 5 Brian Fitzpatrick 2014-08-27 14:13:25 UTC
Created SWITCHYARD-2291 but it's not allowing me to link it here for some reason.

Comment 6 Brian Fitzpatrick 2014-09-12 12:42:56 UTC
I just tried on ubuntu 14.04 LTS 64-bit and am unable to reproduce this one with Open JDK 7. This was with Ubuntu, Eclipse Luna, JBoss Tools, the latest SwitchYard build and OpenJDK 7.

Are you just seeing this with the Sun Java?

Comment 7 Martin Basovník 2014-09-12 13:54:51 UTC
I am able to reproduce this issue on both Oracle JDK and OpenJDK. You have to clean maven project before trying to generate WSDL file.

Comment 8 Brian Fitzpatrick 2014-09-12 14:13:34 UTC
That explains it. Thanks Martin!

Comment 9 Brian Fitzpatrick 2014-09-12 18:50:34 UTC
Martin, I added a screen shot to the JIRA - would that help guide users down the right path? The Details pane of the message dialog must be opened to see it, but I think it offers a bit more guidance anyway.

Comment 10 JBoss JIRA Server 2014-11-04 13:20:30 UTC
Andrej Podhradsky <> updated the status of jira SWITCHYARD-2291 to Reopened

Comment 11 JBoss JIRA Server 2014-12-19 22:35:34 UTC
Brian Fitzpatrick <> updated the status of jira SWITCHYARD-2291 to Reopened

Comment 12 JBoss JIRA Server 2015-01-07 15:23:04 UTC
Andrej Podhradsky <> updated the status of jira SWITCHYARD-2291 to Reopened

Comment 13 JBoss JIRA Server 2015-01-08 07:23:01 UTC
Andrej Podhradsky <> updated the status of jira SWITCHYARD-2291 to Closed