Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1062090

Summary: Complete failure after VAR=$(pwd)
Product: [Fedora] Fedora Reporter: Pete Zaitcev <zaitcev>
Component: bash-completionAssignee: Ville Skyttä <ville.skytta>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 20CC: ooprala, sheltren, ville.skytta
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-01-15 20:50:52 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Pete Zaitcev 2014-02-06 05:52:13 UTC
Description of problem:

TAB stops working after PYTHONPATH=$(pwd). This used to work
in F19.

Version-Release number of selected component (if applicable):

bash-completion-2.1-3.fc20.noarch

How reproducible:

100%

Steps to Reproduce:
1. touch foo
2. XXX=$(pwd) ls fo<TAB>

Actual results:

Nothing happens

Expected results:

TAB-completion

Additional info:

If you just do XXX=xxx ls fo<TAB> then it completes as usual.
It's something about $(pwd) that kills the completion.

Comment 1 Ondrej Oprala 2015-01-15 14:40:03 UTC
Hi, works for me on F21, can you still reproduce it there?

Comment 2 Pete Zaitcev 2015-01-15 20:50:52 UTC
Works in F21, closing.